ZOJ3878 onvert QWERTY to Dvorak

Edward, a poor copy typist, is a user of the Dvorak Layout. But now he has only a QWERTY Keyboard with a broken Caps Lock key, so Edward never presses the broken Caps Lock key. Luckily, all the other keys on the QWERTY keyboard work well. Every day, he has a lot of documents to type. Thus he needs a converter to translate QWERTY into Dvorak. Can you help him?

The QWERTY Layout and the Dvorak Layout are in the following:

Qwerty Layout
The QWERTY Layout

Dvorak Layout
The Dvorak Layout

Input

A QWERTY document Edward typed. The document has no more than 100 kibibytes. And there are no invalid characters in the document.

<h4< dd="">
Output

The Dvorak document.

<h4< dd="">
Sample Input
Jgw Gqm Andpw a H.soav Patsfk f;doe
Nfk Gq.d slpt a X,dokt vdtnsaohe
Kjd yspps,glu pgld; aod yso kd;kgluZ
1234567890
`~!@#$%^&*()}"']_+-=ZQqWEwe{[\|
ANIHDYf.,bt/
ABCDEFuvwxyz
<h4< dd="">
Sample Output
Hi, I'm Abel, a Dvorak Layout user.
But I've only a Qwerty keyboard.
The following lines are for testing:
1234567890
`~!@#$%^&*()+_-={}[]:"'<>,.?/\|
ABCDEFuvwxyz
AXJE>Ugk,qf;


简单题,注意两个键盘中单词是如何对应的

#include <iostream>
#include <string>
#include <cstdio>
#include <cstring>
using namespace std;

char fun(char c)
{
    if (c == 'Q')
        return '\"';
    if (c == 'q')
        return '\'';
    if (c == 'W')
        return '<';
    if (c == 'w')
        return ',';
    if (c == 'E')
        return '>';
    if (c == 'e')
        return '.';
    if (c == 'R')
        return 'P';
    if (c == 'r')
        return 'p';
    if (c == 'T')
        return 'Y';
    if (c == 't')
        return 'y';
    if (c == 'Y')
        return 'F';
    if (c == 'y')
        return 'f';
    if (c == 'U')
        return 'G';
    if (c == 'u')
        return 'g';
    if (c == 'I')
        return 'C';
    if (c == 'i')
        return 'c';
    if (c == 'O')
        return 'R';
    if (c == 'o')
        return 'r';
    if (c == 'P')
        return 'L';
    if (c == 'p')
        return 'l';
    if (c == '{')
        return '?';
    if (c == '[')
        return '/';
    if (c == '}')
        return '+';
    if (c == ']')
        return '=';
    if (c == '-')
        return '[';
    if (c == '_')
        return '{';
    if (c == '+')
        return '}';
    if (c == '=')
        return ']';
    if (c == 'S')
        return 'O';
    if (c == 's')
        return 'o';
    if (c == 'D')
        return 'E';
    if (c == 'd')
        return 'e';
    if (c == 'F')
        return 'U';
    if (c == 'f')
        return 'u';
    if (c == 'G')
        return 'I';
    if (c == 'g')
        return 'i';
    if (c == 'H')
        return 'D';
    if (c == 'h')
        return 'd';
    if (c == 'J')
        return 'H';
    if (c == 'j')
        return 'h';
    if (c == 'K')
        return 'T';
    if (c == 'k')
        return 't';
    if (c == 'L')
        return 'N';
    if (c == 'l')
        return 'n';
    if (c == ':')
        return 'S';
    if (c == ';')
        return 's';
    if (c == '\"')
        return '_';
    if (c == '\'')
        return '-';
    if (c == 'Z')
        return ':';
    if (c == 'z')
        return ';';
    if (c == 'X')
        return 'Q';
    if (c == 'x')
        return 'q';
    if (c == 'C')
        return 'J';
    if (c == 'c')
        return 'j';
    if (c == 'V')
        return 'K';
    if (c == 'v')
        return 'k';
    if (c == 'B')
        return 'X';
    if (c == 'b')
        return 'x';
    if (c == 'N')
        return 'B';
    if (c == 'n')
        return 'b';
    if (c == '<')
        return 'W';
    if (c == ',')
        return 'w';
    if (c == '>')
        return 'V';
    if (c == '.')
        return 'v';
    if (c == '?')
        return 'Z';
    if (c == '/')
        return 'z';
    return c;
}
char c;
int main()
{
//    freopen("in.txt", "r", stdin);
    while (~scanf("%c", &c))
        cout << fun(c);
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值