POJ 2387 Til the Cows Come Home 【最短路(dijkstra)】

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.


题意:有N条路,以及T个不同路之间的关系,问从1到N所需的最短时间。
思路:很明显的最短路问题。
AC代码:
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
#define INF 100000000
#define maxn 1001
using namespace std;
bool vis[maxn];   //是否访问过
int adj[maxn][maxn],dis[maxn];  //两点之间的距离  起点到此点的距离
int n, m;
void dijkstra(int v)
{
    int i, j, tem, minx;
    memset(vis, 0, sizeof(vis));
    for(i = 0; i <= n; i++)
        dis[i] = adj[v][i];
    vis[v] = 1;
    dis[v] = 0;
    for(i = 1; i < n; i++)
    {
        minx = INF;
        for(j = 1; j <= n; j++)
        {
            if(!vis[j] && dis[j] < minx)
            {
                minx = dis[j];
                tem = j;
            }
        }
        if(minx == INF) break;
        vis[tem] = 1;
        for(j = 1; j <= n; j++)
        {
            if(!vis[j] && adj[tem][j] != INF && dis[tem] + adj[tem][j] < dis[j])
            {
                dis[j] = dis[tem] + adj[tem][j];  //v->j == v->u + u->j
            }
        }
    }
}
int main()
{
    int i, j, x, y, w;
    while(~scanf("%d%d",&m,&n))
    {
        for(i = 1; i <= n; i++)
        {
            for(j = 1; j <= n; j++)
                if(i == j)  adj[i][j] = 0;
                else adj[i][j] = INF;
        } //初始化
        while(m--)
        {
            scanf("%d%d%d",&x,&y,&w);
            if(w < adj[x][y]) adj[x][y] = adj[y][x] = w;
        }
        dijkstra(1); //起点为1
        printf("%d\n",dis[n]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。
【优质项目推荐】 1、项目代码均经过严格本地测试,运行OK,确保功能稳定后才上传平台。可放心下载并立即投入使用,若遇到任何使用问题,随时欢迎私信反馈与沟通,博主会第一时间回复。 2、项目适用于计算机相关专业(如计科、信息安全、数据科学、人工智能、通信、物联网、自动化、电子信息等)的在校学生、专业教师,或企业员工,小白入门等都适用。 3、该项目不仅具有很高的学习借鉴价值,对于初学者来说,也是入门进阶的绝佳选择;当然也可以直接用于 毕设、课设、期末大作业或项目初期立项演示等。 3、开放创新:如果您有一定基础,且热爱探索钻研,可以在此代码基础上二次开发,进行修改、扩展,创造出属于自己的独特应用。 欢迎下载使用优质资源!欢迎借鉴使用,并欢迎学习交流,共同探索编程的无穷魅力! Java基于安卓系统开发的时间管理软件APP源码+设计报告+apk安装包.zipJava基于安卓系统开发的时间管理软件APP源码+设计报告+apk安装包.zipJava基于安卓系统开发的时间管理软件APP源码+设计报告+apk安装包.zipJava基于安卓系统开发的时间管理软件APP源码+设计报告+apk安装包.zipJava基于安卓系统开发的时间管理软件APP源码+设计报告+apk安装包.zipJava基于安卓系统开发的时间管理软件APP源码+设计报告+apk安装包.zipJava基于安卓系统开发的时间管理软件APP源码+设计报告+apk安装包.zipJava基于安卓系统开发的时间管理软件APP源码+设计报告+apk安装包.zipJava基于安卓系统开发的时间管理软件APP源码+设计报告+apk安装包.zip

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值