K贪心

<span style="color:#330099;">/*
K - 贪心 基础
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. 
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain. 
 
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000. 
 
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain. 
 
Sample Input
 5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1 
 
Sample Output
 13.333
31.500 
 BY Grant Yuan
 2014.7.14
 贪心
 */
 /*
描述
有一个投资人,他有金钱m,可选投资项目n个。对于每个投资项目,投入金钱c则获得收益f。要求对每个项目所投入的资金r应该在0到c之间(即0<=r<=c),获得的收益为r*f/c。现在你的任务就是求出投资人能获得的最大收益。


输入
包括多个测例,每个测例第一行为两个整数m,n,分别表示金钱数和项目个数。接下来n行,每行两个整数为收益f和投入c。输入最后以两个-1结尾。


输出
包括n行,每行为对应测例的最大收益,保留三位小数printf("%.3lf\n",result);。


输入样例
3 3
4 2
2 1
3 1
4 3
4 2
5 3
4 3
-1 -1


输出样例
7.000
7.333
By yuan.c
20146/22

提示
*/
#include<stdio.h>
#include<iostream>
#include<cstring>
#include<cstdlib>
using namespace std;
int N;
int M;

double p[1002];
int m[1002];
int s[1002];
double sum=0;

void sort()
{int t;double l;
    for(int i=0;i<N-1;i++)
       for(int j=i;j<N;j++)
         {
             if(p[i]<p[j]){
                 l=p[i],p[i]=p[j],p[j]=l;
                 t=m[i],m[i]=m[j],m[j]=t;
                 t=s[i],s[i]=s[j],s[j]=t;
             }
         }
}

int main()
{
    while(1){
      scanf("%d %d",&M,&N);
      if(N==-1&&M==-1)
        break;
       for(int i=0;i<N;i++)
          scanf("%d %d",&s[i],&m[i]);
      for(int i=0;i<N;i++)
           p[i]=s[i]*1.0/m[i]*1.0;
     sort();
     for(int i=0;i<N;i++)
          if(M>=m[i])
             sum+=s[i],M-=m[i];
        else {sum+=M*p[i];
        break;
        }
        printf("%.3lf\n",sum);
        sum=0;
        memset(s,0,100);
        memset(m,0,100);
        memset(p,0,100);
    }
    return 0;
}
</span>

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值