L贪心基础

<span style="color:#330099;">/*
L - 贪心 基础
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
Description
Once upon a time, in the Kingdom of Loowater, a minor nuisance turned into a major problem.

The shores of Rellau Creek in central Loowater had always been a prime breeding ground for geese. Due to the lack of predators, the geese population was out of control. The people of Loowater mostly kept clear of the geese. Occasionally, a goose would attack one of the people, and perhaps bite off a finger or two, but in general, the people tolerated the geese as a minor nuisance.

One day, a freak mutation occurred, and one of the geese spawned a multi-headed fire-breathing dragon. When the dragon grew up, he threatened to burn the Kingdom of Loowater to a crisp. Loowater had a major problem. The king was alarmed, and called on his knights to slay the dragon and save the kingdom.

The knights explained: "To slay the dragon, we must chop off all its heads. Each knight can chop off one of the dragon's heads. The heads of the dragon are of different sizes. In order to chop off a head, a knight must be at least as tall as the diameter of the head. The knights' union demands that for chopping off a head, a knight must be paid a wage equal to one gold coin for each centimetre of the knight's height."

Would there be enough knights to defeat the dragon? The king called on his advisors to help him decide how many and which knights to hire. After having lost a lot of money building Mir Park, the king wanted to minimize the expense of slaying the dragon. As one of the advisors, your job was to help the king. You took it very seriously: if you failed, you and the whole kingdom would be burnt to a crisp!

Input
The input contains several test cases. The first line of each test case contains two integers between 1 and 20000 inclusive, indicating the number n of heads that the dragon has, and the number m of knights in the kingdom. The next n lines each contain an integer, and give the diameters of the dragon's heads, in centimetres. The following m lines each contain an integer, and specify the heights of the knights of Loowater, also in centimetres.

The last test case is followed by a line containing:

0 0

Output
For each test case, output a line containing the minimum number of gold coins that the king needs to pay to slay the dragon. If it is not possible for the knights of Loowater to slay the dragon, output the line:

Loowater is doomed!

Sample Input
2 3
5
4
7
8
4
2 1
5
5
10
0 0
Sample Output
11
Loowater is doomed!
By Grant Yuan
2014.7.14
贪心
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;
int m,n;
int a[20001];
int b[20001];
int main()
{ int sum;
    while(1){sum=0;
      cin>>n>>m;
      if(m==0&&n==0)
         break;
      for(int i=0;i<n;i++)
         cin>>a[i];
    for(int j=0;j<m;j++)
        cin>>b[j];
      if(m<n){
           cout<<"Loowater is doomed!"<<endl;
           }
        else{
         sort(a,a+n);
         sort(b,b+m);
         int i=0;
           for(int j=0;j<m;j++)
             {
                if(b[j]>=a[i]){
                  i++;
                  sum+=b[j];}
                  if(i==n) break;}
            if(i==n) cout<<sum<<endl;
            else cout<<"Loowater is doomed!"<<endl;
        }}
        return 0;
}
</span>

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
贪心算法是一种在每一步选择中都采取在当前状态下最好或最优(即最有利)的选择,从而希望导致结果是全局最优的算法策略。虽然贪心算法并不保证一定能找到全局最优解,但在某些情况下,它们能提供接近最优的结果,并且由于其简单性和效率而被广泛应用。 一些关于贪心算法的经典参考文献包括: 1. "Introduction to Algorithms" by Thomas H. Cormen, Charles E. Leiserson, Ronald L. Rivest, and Clifford Stein. 这本书是计算机科学领域最著名的教材之一,其中第26章专门讨论了贪心算法和动态规划,适合深入学习。 2. "The Algorithm Design Manual" by Steven S. Skiena. 这本书提供了很多实用的算法和技巧,其中包括对贪心算法的详细探讨。 3. "Greedy Algorithms" by Michael T. Goodrich and Roberto Tamassia. 这是一本专注于贪心算法的专业书籍,深入讲解了算法设计中的贪心策略。 4. "Computational Geometry: An Introduction" by Mark de Berg, Otfried Schwarzkopf, Harald Welzl, and Anna Wormald. 如果你在图形学或计算机视觉领域使用贪心算法,这本书会是个好选择。 5. "Algorithmic Game Theory" by Nisan and Roughgarden (特别是第二部分)。虽然这不是专门讲贪心算法的书,但里面包含了许多与算法和经济理论结合的案例,其中可能有涉及贪心算法的应用。 如果你对某个特定领域的贪心算法感兴趣,如网络流、图论或者优化问题,可以在这些书籍的基础上搜索相关的子章节或者论文。记得查阅最新的学术论文,因为算法领域的研究是不断进化的。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值