Dragon of Loowater UVA11292

Once upon a time, in the Kingdom of Loowater, a minor nuisance turned into a major problem.
The shores of Rellau
Creek in central Loowater
had always been a prime
breeding ground for geese.
Due to the lack of predators,
the geese population was out
of control. The people of
Loowater mostly kept clear
of the geese. Occasionally,
a goose would attack one of
the people, and perhaps bite
off a finger or two, but in
general, the people tolerated
the geese as a minor nuisance.
One day, a freak mutation occurred, and one
of the geese spawned a
multi-headed fire-breathing
dragon. When the dragon grew up, he threatened to burn the Kingdom of Loowater to a crisp.
Loowater had a major problem. The king was alarmed, and called on his knights to slay the dragon
and save the kingdom.
The knights explained: “To slay the dragon, we must chop off all its heads. Each knight can chop
off one of the dragon’s heads. The heads of the dragon are of different sizes. In order to chop off a
head, a knight must be at least as tall as the diameter of the head. The knights’ union demands that
for chopping off a head, a knight must be paid a wage equal to one gold coin for each centimetre of the
knight’s height.”
Would there be enough knights to defeat the dragon? The king called on his advisors to help him
decide how many and which knights to hire. After having lost a lot of money building Mir Park, the
king wanted to minimize the expense of slaying the dragon. As one of the advisors, your job was to
help the king. You took it very seriously: if you failed, you and the whole kingdom would be burnt to
a crisp!
Input
The input contains several test cases. The first line of each test case contains two integers between 1 and
20000 inclusive, indicating the number n of heads that the dragon has, and the number m of knights in
the kingdom. The next n lines each contain an integer, and give the diameters of the dragon’s heads,
in centimetres. The following m lines each contain an integer, and specify the heights of the knights of
Loowater, also in centimetres.
The last test case is followed by a line containing ‘0 0’.
Output
For each test case, output a line containing the minimum number of gold coins that the king needs to
pay to slay the dragon. If it is not possible for the knights of Loowater to slay the dragon, output the
line ‘Loowater is doomed!’.
Sample Input
2 3
5
4
7
8
4
2 1
5
5
10
0 0
Sample Output
11
Loowater is doomed!
题意翻译
你的王国里有一条n个头的恶龙,你希望雇佣一些骑士把它杀死(即砍掉所有头)。村里有m个骑士可以雇佣,一个能力值为x的骑士可以砍掉恶龙一个直径不超过x的头,且需要支付x个金币。如何雇佣骑士才能砍掉龙的所有头,且需要支付的金币最少?注意,一个骑士只能砍一个头。(且不能被雇佣两次)。 输入格式

输入包含多组数据。每组数据的第一行为正整数n和m(1<=n,m<=20000);以下n行每行为一个整数,即恶龙每个头的直径;以下m行每行为一个整数,即每个骑士的能力。输入结束标志为n=m=0。 输出格式

对于每组数据,输出最小花费。如果无解,输出“Loowater is doomed!”。

#include<iostream>
#include<algorithm>
#include<cstring>

using namespace std;

const int N = 20100;
int a[N], b[N], vis[N];

int main()
{
    int n, m;
    while (cin >> n >> m && m && n)
    {
        memset(vis, 0, sizeof(vis));
        for (int i = 0; i < n; i ++)
            cin >> b[i];
        for (int i = 0; i < m; i ++)
            cin >> a[i];
        sort(a, a + m);
        sort(b, b + n);
        int ans = 0;
        int sum = 0;
        for (int i = n - 1; i >= 0; i --)
        {
            for (int j = 0; j < m; j ++)
            {
                if (vis[j])
                    continue;
                if (a[j] >= b[i])
                {
                    vis[j] = 1;
                    ans += a[j];
                    sum++;
                    break;
                }
            }
        }
        if (sum < n)
            cout << "Loowater is doomed!" << endl;
        else
            cout << ans << endl;
    }
    return 0;
}
  • 10
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

比奇堡碌碌无为比目鱼

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值