POJ 3468 线段树+lazy标记


lazy标记
  Time Limit:5000MS     Memory Limit:131072KB     64bit IO Format:%I64d & %I64u 
Submit Status



Description



You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.


Input



The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C abc" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q ab" means querying the sum of Aa, Aa+1, ... , Ab.


Output



You need to answer all Q commands in order. One answer in a line.


Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4



Sample Output

4
55
9
15


Hint


The sums may exceed the range of 32-bit integers.

<span style="color:#6633ff;">/********************************************************
    author    :    Grant Yuan
    time      :    2014.7.28
    algorithm :    线段树+lazy标记
    source    :    POJ 3468
    
*********************************************************/

#include <iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#define MAX 100003
#define LL long long

using namespace std;
struct node{
LL l;
LL r;
LL sum;
LL lazy;
};
node tree[3*MAX];
int n,m;
LL input[MAX],ans;

void build(LL left,LL right,LL root)
{
    tree[root].lazy=0;
    tree[root].l=left;
    tree[root].r=right;
    if(left==right){
        tree[root].sum=input[left];
        return;
    }
    int mid=(left+right)>>1;
    build(left,mid,root*2);
    build(mid+1,right,root*2+1);
    tree[root].sum=tree[root*2].sum+tree[root*2+1].sum;
}

void upchild(LL root)
{
    if(tree[root].lazy){
        tree[root<<1].sum+=(tree[root<<1].r-tree[root<<1].l+1)*tree[root].lazy;
        tree[(root<<1)|1].sum+=(tree[(root<<1)|1].r-tree[(root<<1)|1].l+1)*tree[root].lazy;
        tree[root<<1].lazy+=tree[root].lazy;
        tree[root<<1|1].lazy+=tree[root].lazy;
        tree[root].lazy=0;
    }
}

void update(LL left,LL right,LL root,LL p)
{
   if(left<=tree[root].l&&right>=tree[root].r)
   {
       tree[root].sum+=(LL)(tree[root].r-tree[root].l+1)*p;
       tree[root].lazy+=(LL)p;
       return;
   }
   upchild(root);
   int mid=(tree[root].l+tree[root].r)>>1;
   if(mid<right)
      update(left,right,root*2+1,p);
  if(mid>=left)
      update(left,right,root*2,p);
      tree[root].sum=tree[root<<1].sum+tree[(root<<1)|1].sum;
}

void query(LL left,LL right,LL root)
{
    if(left<=tree[root].l&&right>=tree[root].r)
    {   
        ans+=(LL)tree[root].sum;
        return;
    }
    upchild(root);
    int mid=(tree[root].l+tree[root].r)>>1;
    if(mid>=left)
        query(left,right,root<<1);
    if(mid<right)
        query(left,right,root*2+1);
}

int main()
{   char s;LL a,b,q;
    while(~scanf("%d%d",&n,&m)){
        for(int i=1;i<=n;i++)
            scanf("%lld",&input[i]);
        build(1,n,1);
        for(int i=0;i<m;i++)
        {  getchar();
           scanf("%c",&s);
           if(s=='Q'){
                ans=0;
            scanf("%lld%lld",&a,&b);
            query(a,b,1);
           printf("%lld\n",ans);
           }
           else if(s=='C'){
            scanf("%lld%lld%lld",&a,&b,&q);
            update(a,b,1,q);
           }
        }
    }
    return 0;
}
</span>


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值