POJ 3468 线段树加lazy标记模板

题目

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

输入

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

输出

You need to answer all Q commands in order. One answer in a line.

样例输入

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

样例输出

4
55
9
15

提示

The sums may exceed the range of 32-bit integers.

个人总结

这是一道基础的线段树+lazy标记的模板题,但是个人对线段树+lazy的模板还不是很熟悉,需要多应用。还有update函数这里不是单点更新,要注意单点更新和区间更新的区别。

AC代码

#include<iostream>
#include<cstdio>
using namespace std;
const int maxn=100005;
long long tree[maxn<<2],lazy[maxn<<2];
int A[maxn];
int N,Q;
void build(int id,int l,int r){
	if(l==r){
		tree[id]=A[l];
		return;
	}
	int mid=(l+r)>>1;
	build(id<<1,l,mid);
	build(id<<1|1,mid+1,r);
	tree[id]=tree[id<<1]+tree[id<<1|1];
}
void pushdown(int id,int l,int r){
	lazy[id<<1]+=lazy[id];
	lazy[id<<1|1]+=lazy[id];
	int mid=(l+r)>>1;
	tree[id<<1]+=(mid-l+1)*lazy[id];
	tree[id<<1|1]+=(r-mid)*lazy[id];
	lazy[id]=0;
}
void update(int id,int l,int r,int a,int b,int c){
	if(a<=l&&r<=b){
		tree[id]+=(r-l+1)*c;
		lazy[id]+=c;
		return;
	}
	pushdown(id,l,r);
	int mid=(l+r)>>1;
	if(a<=mid){
		update(id<<1,l,mid,a,b,c);
	}
	if(b>mid)update(id<<1|1,mid+1,r,a,b,c);
	tree[id]=tree[id<<1]+tree[id<<1|1];
}
long long query(int id,int l,int r,int a,int b){
	if(a<=l&&r<=b){
		return tree[id];
	}
	pushdown(id,l,r);
	long long ans=0;
	int mid=(l+r)>>1;
	if(a<=mid){
		ans=query(id<<1,l,mid,a,b);
	}
	if(b>mid)ans+=query(id<<1|1,mid+1,r,a,b);
	return ans;
}
int main(){
	scanf("%d%d",&N,&Q);
	for(int i=1;i<=N;i++){
		scanf("%d",&A[i]);
	}
	build(1,1,N);
	char QQ[10];
	int a,b,c;
	for(int i=1;i<=Q;i++){
		scanf("%s%d%d",QQ,&a,&b);
		if(QQ[0]=='C'){
			scanf("%d",&c);
			update(1,1,N,a,b,c);
		}
		else{
			printf("%lld\n",query(1,1,N,a,b));
		}
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值