POJ 2533-Longest Ordered Subsequence

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 36253 Accepted: 15921

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

小结:

        关于这道题目,理论上有多种方法,我也是参考了各种方法尝试了各种方法...都是泪啊..

        首先是dp,状态转移方程是dp[i]=max(dp[i],dp[j]+1),0<=j<i。

以下是dp的代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
using namespace std;
int dp[1500];
int num[1500];
void init(int n)
{
    for(int i=0;i<=n;i++)
    dp[i]=1;
}
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    scanf("%d",&num[i]);
    init(n);
    int temp,m=0;
    for(int i=0;i<n;i++)
    {
        temp=0;
        for(int j=0;j<i;j++)
        {
            if(num[i]>num[j])
            temp=max(temp,dp[j]);
        }
        dp[i]=temp+1;
        m=max(m,dp[i]);
    }
    printf("%d\n",m);
    return 0;
}

然后就是运用C++强大功能的方法,利用lower_bound函数,目的是返回不小于某值的下标最小的指针。

以下是利用lower_bound函数实现的代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
using namespace std;
const int INF (99999999);
int dp[1500];
int a[1500];
void init(int n)
{
    for(int i=0;i<=n;i++)
    dp[i]=INF;
}
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    scanf("%d",&a[i]);
    init(n);
    for(int i=0;i<n;i++)
    *lower_bound(dp,dp+n,a[i])=a[i];
    printf("%d\n",lower_bound(dp,dp+n,INF)-dp);
    return 0;
}

然后就是我个人的方法了,仅供参考...大家看着办吧...

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<map>
using namespace std;
int num[1005];
int step;
int main()
{
    int n,temp;
    step=0;
    scanf("%d",&n);
    if(n==1)
    {
        scanf("%d",&temp);
        printf("1\n");
        return 0;
    }
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&temp);
        if(i==1||temp>num[step-1])
        num[step++]=temp;
        else
        *lower_bound(num,num+step,temp)=temp;
    }
    printf("%d\n",step);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值