Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 4494 | Accepted: 2038 |
Description
Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.
Input
The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.
Output
For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.
Sample Input
2 1 2
Sample Output
2 6
今天最后一篇博客也该落幕了,快速幂算法也感觉有点理解了。
这类题目的关键是找到递推方程,然后通过线性代数矩阵的乘法来快速求出结果,方法十分巧妙,最初想到这种算法的人真的是个天才!
以下是AC代码:
#include<cstdio>
#include<cstring>
#include<cmath>
#include<ctype.h>
#include<algorithm>
#include<vector>
#include<map>
using namespace std;
typedef vector<int> vec;
typedef vector<vec> mat;
typedef long long ll;
const int mod = 10007;
mat mul(mat &a,mat &b)
{
mat c(a.size(),vec(b[0].size()));
for(int i=0;i<a.size();i++)
for(int k=0;k<b.size();k++)
for(int j=0;j<b[0].size();j++)
{
c[i][j]=(c[i][j]+a[i][k]*b[k][j])%mod;
}
return c;
}
mat pow_mul(mat a,ll num)
{
mat b(a.size(),vec(a[0].size()));
for(int i=0;i<a.size();i++)
b[i][i]=1;
while(num)
{
if(num&1)
b=mul(b,a);
a=mul(a,a);
num>>=1;
}
return b;
}
int main()
{
ll n;
int t;
scanf("%d",&t);
for(int i=1;i<=t;i++)
{
mat a(3,vec(3));
a[0][0]=2; a[0][1]=1; a[0][2]=0;
a[1][0]=2; a[1][1]=2; a[1][2]=2;
a[2][0]=0; a[2][1]=1; a[2][2]=2;
scanf("%lld",&n);
a=pow_mul(a,n);
printf("%d\n",a[0][0]);
}
return 0;
}