POJ 3254-Corn Fields

Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9051 Accepted: 4804

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

Source


小结:

        这是我做的第一道状态压缩dp题目,发现状态压缩dp远没有想象中的那么难嘛!

        看别人代码,一直的感觉是冗长加上繁琐,可能别人也是这么看待我的代码的吧。

        这道题目如果没有一定的剪枝技巧(嘛,虽然是很基础的剪枝技巧),基本可以确定是TLE,最后AC显示出来的时间竟然只有31ms,看来数据还是比较好过的,没有特别坑爹的数据。

        表示不止是状态压缩dp,dp一类的题目感觉都不是靠别人教就能教会的,这还需要自己多做多想,才能运用,所以啦,这里我就只贴出代码啦,啦啦啦....

以下是AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<ctype.h>
using namespace std;
const int m=13;
typedef long long ll;
const int mod=100000000;
int check(int num)
{
    while(num)
    {
        if(num%2==1&&(num/2)%2==1)
        return 0;
        num>>=1;
    }
    return 1;
}
int main()
{
    int row,col,maxn;
    int map[13][13],statue[13];
    ll dp[13][2<<13];
    while(~scanf("%d%d",&row,&col))
    {
        maxn=0;
        memset(dp,0,sizeof(dp));
        memset(map,0,sizeof(map));
        memset(statue,0,sizeof(statue));
        for(int i=1;i<=row;i++)
        for(int j=1;j<=col;j++)
        {
            scanf("%d",&map[i][j]);
            statue[i]<<=1;
            statue[i]=statue[i]|map[i][j];
        }
        for(int i=1;i<=row;i++)
        maxn=max(maxn,statue[i]);
        for(int j=0;j<=maxn;j++)
        {
            if((j|statue[1])==statue[1]&&check(j))
            {
                dp[1][j]++;
            }
        }
        for(int i=2;i<=row;i++)
        for(int j=0;j<=maxn;j++)
        {
            if(!dp[i-1][j])
            continue;
            for(int k=0;k<=maxn;k++)
            {
                if((k|statue[i])!=statue[i]||!check(k)||(k&j)!=0)
                continue;
                dp[i][k]+=dp[i-1][j];
                dp[i][k]%=mod;
            }
        }
        ll ans=0;
        for(int j=0;j<=maxn;j++)
        ans=(ans+dp[row][j])%mod;
        printf("%lld\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值