Description
在计算机及其网络应用如此普及的当今时代,字符处理比重很大。现有多行字符串清单,针对每个清单,需要根据需要从里面提取各种信息。如是’A’标志,提取数据求和;是’B’标志,提取英文字符数量;是’C’标志,则提取数字字符数量。
Input
给定不定组数的数据,每组数据中有两行,第一行是提取标识;第二行待处理的字符串。
Output
标志如果是A,输出从字符串中提取的数据和,保留两位小数;
标志如果是B,输出字符串中英文字符的数量;
标志如果是C,输出字符串中数字字符的数量。
具体参见样例。
Sample Input
A tv:1000.0
;
p
h
o
n
e
:
300
; phone:300
;phone:300;car:2000.0$;
B Total Submit: 102 (62 users)
C Total Accepted: 64 (62 users)
C 1999,13112345678
Sample Output
3300.00
16
4
15
import java.util.*;
public class Main {
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner reader = new Scanner(System.in);
while (reader.hasNext()) {
double sum = 0;
char s;
s = reader.next().charAt(0);
String a;
a = reader.nextLine();
if (s == ‘A’) {
Scanner sc = new Scanner(a);
sc.useDelimiter("[^0-9.]+");
while (sc.hasNextDouble())
sum += sc.nextDouble();
System.out.printf("%.2f\n", sum);
}
if (s == ‘C’) {
int q = 0;
for (int i = 0; i < a.length(); i++) {
if (a.charAt(i) <= 57 && a.charAt(i) >= 48) {
q++;
}
}
System.out.println(q);
}
if (s == ‘B’) {
int p = 0;
for (int i = 0; i < a.length(); i++) {
if ((a.charAt(i) <= 90 && a.charAt(i) >= 65) || (a.charAt(i) >= 97 && a.charAt(i) <= 122)) {
p++;
}
}
System.out.println§;
}
}
}
}
import java.util.Scanner;
import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Main {
public static void main(String[] args) {
Scanner in=new Scanner(System.in);
while(in.hasNext())
{
String x=in.next();
in.nextLine();
String c=in.nextLine();
if(x.charAt(0)=='A')
{
double sum=0,a=0;
int q=0,p=0;
double b=0;
for(int i=0;i<c.length();i++)
{
if(c.charAt(i)>='0'&&c.charAt(i)<='9')
{
if(q==0)
{
sum=sum*10+(c.charAt(i)-'0');
}
else
{
a=a*10+(c.charAt(i)-'0');
p++;
}
}
else if(c.charAt(i)=='.'&&c.charAt(i+1)>='0'&&c.charAt(i+1)<='9')
{
if(q==0)
{
p=0;
q=1;
}
else
{
q=0;
if(p!=0)
{
double t=0.1;
for(int o=0;o<p;o++)
{
t*=0.1;
}
sum+=a*t;
b+=sum;
}
}
}
else
{
if(q==0)
{
b+=sum;
sum=0;
}
else
{
if(p!=0)
{
double t=0.1;
for(int o=0;o<p;o++)
{
t*=0.1;
}
sum+=a*t;
b+=sum;
sum=0;
}
q=0;
}
}
}
System.out.printf("%.2f\n",b);
}
else if(x.charAt(0)=='B')
{
int cnt=0;
for(int w=0;w<c.length();w++)
{
if((c.charAt(w)>='a'&&c.charAt(w)<='z')||(c.charAt(w)>='A'&&c.charAt(w)<='Z'))
{
cnt++;
}
}
System.out.println(cnt);
}
else
{
int cnt=0;
for(int w=0;w<c.length();w++)
{
if((c.charAt(w)>='0'&&c.charAt(w)<='9'))
{
cnt++;
}
}
System.out.println(cnt);
}
}
}
}