M - Exponentiation

M - Exponentiation
Time Limit:500MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R  n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201


题意仍然十分简单明了,输入一个带小数的数S,然后输入一个N,求S的N次方并输出。


题目限定了S占用的输入前1~6位,接下来的N占用第8~9位,因为S是从(0,99.999),所以输入的时候会出现前导后导0,不过因为题目已经限定了是哪几位,所以很容易的去掉前后导零,然后暴力模拟就好。


输出的时候有点需要注意的,咱的思路是在预先处理以及高精度模拟的时候都不去掉后导零,将后导零也算作是一位小数,然后统计出输入了几位小数,那么就可以很方便的求出结果会有几位小数,然后在输出的时候将前导后导零都去掉,这里需要注意有三种情况:

1、小数位数大于答案的总位数,那么需要在前面补零

2、答案既有小数又有整数,那么简单的记录一下小数点在哪一位出现即可

3、答案是一个整百、整千之类的数,那么在去除后导零的时候只能去掉等于小数个数的后导零


#include"iostream"
#include"cstring"
#include"cstdio"

using namespace std;

char s[10];
int num[1005];
int n;

int main(void)
{
    while(~scanf("%s%d",s,&n))
    {
        memset(num,0,sizeof(num));
        int pointpos = 5;
        for(int i = 5,j = 0;i >= 0;i--)
        {
            if(s[i] == '.')
            {
                pointpos = i;
                continue;
            }
            num[j++] = s[i] - '0';
        }
        int numpoint = 5 - pointpos;
        numpoint *= n;
        int len = (pointpos == 5 ? 6 : 5);

        int ans[1005];
        int res[1005];
        memset(res,0,sizeof(res));
        for(int i = 0;i < len;i++) res[i] = num[i];
        for(int tim = 1;tim < n;tim++)
        {
            memset(ans,0,sizeof(ans));
            for(int i = 0;i < len;i++)
            {
                int k = i;
                for(int j = 0;j < 1005;j++)
                {
                    ans[k++] += num[i]*res[j];
                }
            }
            for(int i = 0;i < 1005;i++)
            {
                if(ans[i]/10 != 0)
                {
                    res[i] = ans[i]%10;
                    ans[i+1] += ans[i]/10;
                }
                else
                {
                    res[i] = ans[i];
                }
            }
        }


        int posa;;
        int posb;
        for(posa = 0;posa < 1005;posa++) if(res[posa]) break;
        for(posb = 1004;posb >= 0;posb--) if(res[posb]) break;
        int nums = posb + 1 - numpoint;

        if(nums > 0)
        {
            if(numpoint <= posa)
            {
                for(;posb >= numpoint;posb--) printf("%d",res[posb]);
                printf("\n");
                continue;
            }
            for(int nn = 0;posb >= posa;posb--,nn ++)
            {
                if(nn == nums)
                {
                    printf(".");
                    posb++;
                }
                else printf("%d",res[posb]);
            }
            printf("\n");
        }
        else
        {
            printf(".");
            for(int nn = numpoint - 1;nn >= posa;nn--) printf("%d",res[nn]);
            printf("\n");
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值