Exponentiation

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Hint

If you don't know how to determine wheather encounted the end of input: 
s is a string and n is an integer 

 

这道题主要用到高精度乘法。但是,这道题最关键的还是数据的处理,小数点的位置,结果前面的0,结果后面的0,指数为1和大于1,需要考虑全面,一直wrong,

#include<iostream>
#include<algorithm>
#include<string.h>
#include<string>
using namespace std;

//高精度乘法 
string bigMul(string a,string b)
{
	int lengthA,lengthB,aInt[205],bInt[205],mul[205]={0},mark,start;
	reverse(a.begin(),a.end());
	reverse(b.begin(),b.end());
	lengthA=a.length();
	lengthB=b.length(); 
	for(int i=0;i<lengthA;i++)
	{
		aInt[i]=(int)(a[i]-'0');
	}
	for(int i=0;i<lengthB;i++)
	{
		bInt[i]=(int)(b[i]-'0');
	}
	//开始相乘 
	for(int i=0;i<lengthA;i++)
	{
		for(int j=0;j<lengthB;j++)
		{
			mul[i+j]+=aInt[i]*bInt[j];
		}
	}
	//处理
	for(int i=0;i<lengthA+lengthB;i++)
	{
		mul[i+1]+=(int)mul[i]/10;
		mul[i]=mul[i]%10;
		
	 } 
	 //结果转化成字符串
	 
	char mulChar[205];
	mark=204;
	while(mul[mark]==0)
	   mark--;
	start=0;
	for(int i=mark;i>=0;i--)
	{
		mulChar[start]=(char)(mul[i]+'0');
		start++;
	}
	mulChar[start]='\0';
	return (string)mulChar;
}


int main()
{
	string a;
	int n;
	while(cin>>a>>n)
	{
		int dotPos,resultDotPos; //小数点的位置
		string result=a;
		bool flagDot=true;  //无小数点   
		for(int i=0;i<6;i++)
		{
		    if(a[i]=='.')
		    { 
			    dotPos=i;
			    flagDot=false; 
			    break;
			}
    	}
    	
    	//去掉小数点,a保存到result中 
    	if(n>=2&&!flagDot)  
    	{
    		int start=0;
    		for(int i=0;i<6;i++)
    		{
    			 if(a[i]!='.')
    			 {
    			 	result[start++]=a[i];
				 }
			}
		    result=result.substr(0,5);
		}

		//开始相乘
		if(n>=2)
		{
			string tmp=result;
			for(int i=0;i<n-1;i++)
			{
				result=bigMul(result,tmp);
			}
		} 
		
		//输出处理
		//没有小数点 
		if(flagDot)
		{
			//除去无意义的零 
			int i;
			for( i=0;i<result.length();i++)
			   if(result[i]!='0')
			    break;
			for(;i<result.length();i++)
			   cout<<result[i];
			cout<<endl;	   
		} 
		
		//有小数点 
		else if(n>=2)
		{
			//计算小数点的离最后一位的位置
			resultDotPos=(5-dotPos)*n;
			int lengthResult=result.length();
			//去掉后面无意义的零
			int i=lengthResult-1;
			for(;i>=0;i--)
			   if(result[i]!='0'||(lengthResult-i>resultDotPos))
			   break; 
			result=result.substr(0,i+1);
			
			if(lengthResult<=resultDotPos)
			{
				cout<<".";
				for(int i=0;i<resultDotPos-lengthResult;i++)
				   cout<<"0";
				cout<<result<<endl;
			}
			else
			{
				i=0;
				for(;i<lengthResult-resultDotPos;i++)
				   cout<<result[i];
				if(i!=result.length())
				   cout<<".";
				for(;i<result.length();i++)
				   cout<<result[i];
				cout<<endl;
			} 
		}
		//有小数点且n=1
		else
		{

			int endZeros=5;
			for(;endZeros>=0;endZeros--)
			   if(result[endZeros]!='0'&&result[endZeros]!='.')
			      break;
			if(result[0]=='0'&&dotPos==1)
			{ 
				cout<<".";
				for(int i=2;i<=endZeros;i++)
				  cout<<result[i];
				cout<<endl;
			}
			else
			{
				for(int i=0;i<=(endZeros>(dotPos-1)?endZeros:(dotPos-1));i++)
				   cout<<result[i];
				cout<<endl;
			}
			   
		} 
		
    }
	return 0;
}












不过最后还是通过了。由于没考虑好,后面修改代码比较乱

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值