D - Machine Schedule

D - Machine Schedule
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B . Machine A has n kinds of working modes, which is called mode0 , mode1 , ... , moden-1 , likewise machine B has m kinds of working modes, mode0 , mode1 , ... , modem-1 . At the beginning they are both work at mode0 .

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode3 or in machine B at mode4 , job 1 can either be processed in machine A at mode2 or in machine B atmode4 , and so on. Thus, for job i, the constraint can be represent as a triple (ixy) , which means it can be processed either in machine Aat modex , or in machine B at modey .

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n ,m(nm < 100) and k(k < 1000) . The following k lines give the constrains of the k jobs, each line is a triple: ixy .

The input will be terminated by a line containing a single zero.

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3



题意是告诉你有两台机器A,B,A机器有0~n-1种模式,B机器有0~m-1种模式,然后告诉你有N个零件,对于 i,x,y表示i零件可以由A的x模式或者B的y模式来完成,对于每台机器来说如果要切换模式则需要一个花费,你可以任意选择零件的加工先后和机器使用,问你最小花费为多少。


其实我们可以注意到花费和零件根本都没有任何关系,实际上这个问题可以等价于在x,y之间连一条边,然后求最小点覆盖(最大二分匹配),使用匈牙利算法即可。


需要注意的是,因为两台机器的初始模式为0,所以如果x,y其中一个为0那么实际上是可以当成不存在的,不需要加入边。


#include"iostream"
#include"cstring"
#include"cstdio"

using namespace std;

bool line[105][105];
bool vis[105];
int link[105];
int n,m,k;

int find(int x)
{
    int i,j;
    for(i = 0;i < m;i++)
    {
        if(line[x][i] && !vis[i])
        {
            vis[i] = true;
            if(link[i] == -1 || find(link[i]))
            {
                link[i] = x;
                return true;
            }
        }
    }
    return false;
}

int main(void)
{
    while(~scanf("%d",&n) && n)
    {
        scanf("%d%d",&m,&k);
        memset(line,false,sizeof(line));
        while(k--)
        {
            int i,x,y;
            scanf("%d%d%d",&i,&x,&y);
            if(x > 0 && y > 0)
            {
                line[x][y] = true;
            }
        }
        int ans = 0;
        memset(link,-1,sizeof(link));
        for(int i = 0;i < n;i++)
        {
            memset(vis,false,sizeof(vis));
            if(find(i)) ans ++;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值