[POJ1847](最短路floyd)Tram

POJ1847Tram

题目

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer “-1”.

Sample Input

3 2 1
2 2 3
2 3 1
2 1 2

Sample Output

0

思路

模板题
主要理解题意,我用的Floyd算法,毕竟n<=100。
题目大意:
第一行输入这个车站有n个站点,求从a站点到b站点最少需要转弯多少次;
下面有n行,每一行先输入一个m,表示从这个站点有m条线路,第一个站点不用转弯,从第二个站点往后都需要转一次弯。
题目样例就是:
3 2 1 有3个站点,计算从第2个站点到第1个站点最少需要转弯几次。
2 2 3 第1个站点可以通向2和3,通向2不需要转弯,通向3需要转一次弯。
2 3 1 第2个站点可以通向3和1,通向3不需要转弯,通向1需要转一次弯。
2 1 2 第2个站点可以通向1和2,通向1不需要转弯,通向2需要转一次弯。

代码

#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<ctype.h>
#include<queue>
#include<set>
#include<stack>
#include<cmath>
const int inf=99999999;
using namespace std;
int dis[101][101];
int main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);cout.tie(0);
	int k,i,j,n,m,a,b,c;
	cin>>n>>a>>b;
	for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
			if(i==j)  dis[i][j]=0;
			else dis[i][j]=inf;
	for(i=1;i<=n;i++)
	{
		cin>>m>>c;
		dis[i][c]=0;
		for(j=2;j<=m;j++)
		{
			cin>>c;
			dis[i][c]=1;
		}
	}
	for(k=1;k<=n;k++)
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				dis[i][j]=min(dis[i][j],dis[i][k]+dis[k][j]);
	if(dis[a][b]==inf)
		cout<<-1<<endl;
	else
		cout<<dis[a][b]<<endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值