PAT 甲级 1120

                                                                                                                            1120. Friend Numbers (20)
Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different friend ID's among them. Note: a number is considered a friend of itself.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 104.

Output Specification:

For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:
8
123 899 51 998 27 33 36 12
Sample Output:
4

3 6 9 26

【解析】

此题就是求亲朋数,什么是亲朋数呢,就是比如他给你一个n表示总共有n个数,你输入,叫你判断每个数的各个位数总和,不重复的输出。要进行一次排序。本题需要用到set,i插入重复的不会继续插入,以及会自动的排序,这个还是挺好用的。set的应用需要注意

#include<iostream>
#include<string>
#include<stdio.h>
#include<vector>
#include<set>
using namespace std;
int main()
{
    int n,i,j;
    int sum;
    string s1;
    set<int> s;
    cin>>n;
    for(i=0;i<n;i++)
    {
        sum=0;
        cin>>s1;
        for(j=0;j<s1.size();j++)
        sum=sum+s1[j]-'0';
        s.insert(sum);
    }
    cout<<s.size()<<endl;
    cout<<*s.begin();
    set<int>::iterator it;
    for(it=++s.begin();it!=s.end();it++)
        cout<<" "<<*it;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值