PAT甲级1120Tree Traversals(后序中序建树)

1020 Tree Traversals (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

//题意:给你后序,前序,按层次遍历输出

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
struct Node
{
    int num;
    int weight;
    friend bool operator<(const Node &A,const Node &B)
    {
        return A.weight>B.weight;
    }

}node;
priority_queue<Node>q;
void build(int *post,int *in,int len,int w)
{
    if(len<=0)
        return ;
    int index=0;
    while(in[index]!=post[len-1])index++;
    node.num=in[index];
    node.weight=w;
    q.push(node);
    build(post,in,index,w*2);
    build(post+index,in+index+1,len-index-1,w*2+1);
}
int main()
{
    int n;
    scanf("%d",&n);
    int post[40],in[40];
    for(int i=0;i<n;i++)
        scanf("%d",&post[i]);
    for(int i=0;i<n;i++)
        scanf("%d",&in[i]);
    build(post,in,n,1);
    Node temp=q.top();
    printf("%d",temp.num);
    q.pop();
    while(!q.empty())
    {
        temp=q.top();
        printf(" %d",temp.num);
        q.pop();
    }
    printf("\n");
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值