ZCMU-1679-查找2(二分上界)

1679: 查找2

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 253   Solved: 89
[ Submit][ Status][ Web Board]

Description

给你一个长度是n的序列A,然后,有m次询问,每次询问是一个数字X,请你告诉我X在序列A中有多少个数是不大于它的

Input

第一行 ,n,m,(n,m<=100000)

第二行n个数(每个数<=1000)

第三行m个数

Output

输出答案

Sample Input

5 4
2 5 4 3 5
2 5 8 9

Sample Output

1
5
5
5

【解析】
数据太大,普通模拟肯定超时...注意它是求不大于它的有几个所以就要用二分找上界了,把时间复杂度缩小。
#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
using namespace std;
int lower_bound1(int *A, int x, int y, int v)
{
    int m;
    while (x < y)
    {
        m = x + (y - x) / 2;
        if (A[m]<=v)
            x=m+1;
        else
            y=m;
    }
    return x;
}
int main()
{
    int n,m,p,k,i,q;
    while(~scanf("%d%d",&n,&m))
    {
        int a[n];
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        for(i=0;i<m;i++)
        {
            scanf("%d",&q);
        p=lower_bound1(a,0,n,q);
        printf("%d\n",p);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值