ZCMU-训练赛-A

Problem A: Problem A - Y2K Accounting Bug

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 34   Solved: 19
[ Submit][ Status][ Web Board]

Description

Problem A - Y2K Accounting Bug

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.

All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input is a sequence of lines, each containing two positive integers s and d. For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Input

Output

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit

【解析】
这道题就是说公司每五个月算一次账都是亏损的就是说五个月的盈利和亏损加下一起是负的,问你一年下来可以不可以
盈利,如果可以,能赚多少,这个时候我们就要想了怎么样保证它能赚的到钱。总共有五种情况,一种是在五个月当
中只亏一个月,另一种是五个月当中亏两个月,还有就是五个月当中全部亏本,还有个就是五个月当中亏四个月,最
后一种就是五个月全部亏损了。注意我们这是要满足每五个月算起来都是要亏损的。思路源自网络。五种情况都在代码
中列出。
#include<iostream>
using namespace std;
int main()
{
    double s,d;
    while(cin>>s>>d)
    {
        double n;
        if(s>=0 && s<d/4) 
        {
            n=10*s-2*d;//1.SSSSDSSSSDSS
        }
        if(s>=d/4&&s<2*d/3)
        {
        n=8*s-4*d;//2.SSSDDSSSDDSS
        }
        if(s>=2*d/3 && s<3*d/2) 
        {
        n=6*s-6*d;//3.SSDDDSSDDDSS
        }
        if(s>=3*d/2 && s<4*d) 
        {
        n=3*s-9*d;//4.SDDDDSDDDDSD
        }
        if(s<0 || s>=4*d)//每个月都要亏损,所以这样s>=4*d代表每个月都亏损,s<0也代表没有盈利
        {
        n=-1;//5.DDDDDDDDDDDD
        }
        if(n>=0) 
        cout<<n<<endl;
        else 
        cout<<"Deficit\n";
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值