ZCMU-训练赛-Problem A: Freckles

Problem A: Freckles

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 41   Solved: 21
[ Submit][ Status][ Web Board]

Description

Problem A: Freckles

In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through.

Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.

The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

Input

Output

Sample Input

3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output

3.41

【解析】
这道题的意思其实就是叫我们求能连通这几个点的,最短的直线,其实就是最小生成树的问题了,只是最小生成树是给你
点和权重,这里其实给的是距离,我们把距离算出来之后,再进行筛选就比较好做了这里用的是prim算法。
#include<stack>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
#define INF 0x7fffffff
double graph[101][101],distances[101];
int visit[101];
int n;
double prim(int x)
{
    int i,j,mid;
    double sum=0,min1;
    for(i=0;i<n;i++)
    {
        visit[i]=0;//把所有的点先标记成没有访问过的
        distances[i]=graph[x][i];//把以x为起点到i的距离给了distances这个数组
    }
    visit[0]=1;//第一个点记作访问过了
    for(i=1;i<n;i++)
    {
        min1=INF;
        for(j=0;j<n;j++)
        {
            if(min1>distances[j]&&visit[j]==0)//筛选出未到过的点当中哪个距离最小
            {
                min1=distances[j];
                mid=j;
            }
        }
        visit[mid]=1;
        sum+=min1;//加上最小距离
        for(j=0;j<n;j++)
        {
            if(distances[j]>graph[mid][j]&&visit[j]==0)//更新从mid这个点到其余的点
            {
                distances[j]=graph[mid][j];
            }
        }
    }
    return sum;
}
int main()
{
    int i,j,k;
    while(~scanf("%d",&n))
    {
        double a[101],b[101];
        memset(graph,0,sizeof(graph));
        for(i=0;i<n;i++)
        {
            scanf("%lf%lf",&a[i],&b[i]);
        }
        for(i=0;i<n;i++)
        {
            for(j=i+1;j<n;j++)
            {
               graph[i][j]=graph[j][i]=sqrt((a[i]-a[j])*(a[i]-a[j])+(b[i]-b[j])*(b[i]-b[j]));
               //先计算各个点之间的距离
            }
        }
        printf("%.2f\n",prim(0));
    }
 return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值