ZCMU-1441-Parliament

1441: Parliament

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 38   Solved: 17
[ Submit][ Status][ Web Board]

Description

New convocation of The Fool Land's Parliament consists of N delegates. According to the present regulation delegates should be divided into disjoint groups of different sizes and every day each group has to send one delegate to the conciliatory committee. The composition of the conciliatory committee should be different each day. The Parliament works only while this can be accomplished. 
You are to write a program that will determine how many delegates should contain each group in order for Parliament to work as long as possible.

Input

The input file contains a single integer N (5<=N<=1000 ).

Output

Write to the output file the sizes of groups that allow the Parliament to work for the maximal possible time. These sizes should be printed on a single line in ascending order and should be separated by spaces.

Sample Input

7

Sample Output

3 4

【解析】

规律题,题意就是让我们把n拆成几个整数,这几个整数的和肯定要等于n,让这几个数的乘积最大。规律就是每个元素如果能满足相差1那肯定是最大的。我们这么做先从2开始加比如说给出个8从2开始加加到3的时候要停下来了,剩下的还有3,那就先让最大的先加1,这样逐个往前到了最前面了,如果3还没有加完那就继续给最大的那个数+1再继续往前加。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
int main()
{
    int n,m;
    int a[1001];
    while(scanf("%d",&n)!=EOF)
    {
        int sum=0,i,num=0;
        memset(a,0,sizeof(a));

        for(i=2;sum+i<=n;i++)
        {
            sum+=i;
            a[++num]=i;
        }
        if(sum==n)
        {
            for(int j=2;j<i-1;j++)  printf("%d ",j);
            printf("%d\n",i-1);
        }
        else
        {
            int m=num;
            while(n-sum>0)
            {
                a[num]++;
                num--;
                sum++;
                if(num<=0)
                    num=m;
            }
            for(int j=1;j<m;j++)  
                printf("%d ",a[j]);
            printf("%d\n",a[m]);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值