UVa668 - Parliament(贪心)

Parliament 

New convocation of The Fool Land's Parliament consists of N delegates. According to the present regulation delegates should be divided into disjoint groups of different sizes and every day each group has to send one delegate to the conciliatory committee. The composition of the conciliatory committee should be different each day. The Parliament works only while this can be accomplished.


You are to write a program that will determine how many delegates should contain each group in order for Parliament to work as long as possible.

Input 

The first line of the input is an integer M, then a blank line followed by M datasets. There is a blank line between datasets. Each dataset contains a single integer  N  (  $5 \le N \le 1000$ ).

Output 

For each dataset, write to the output file the sizes of groups that allow the Parliament to work for the maximal possible time. These sizes should be printed on a single line in ascending order and should be separated by spaces. Print a blank line between datasets.

Sample Input 

1

31

Sample Output 

2 3 5 6 7 8

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.io.FileReader;
import java.io.PrintWriter;
import java.io.OutputStreamWriter;
import java.io.StreamTokenizer;
import java.io.IOException;

class Main
{
	public static final boolean DEBUG = false;
	public StreamTokenizer tokenizer;
	public PrintWriter cout;
	
	public void init() throws IOException
	{
		
		BufferedReader cin;
		if (DEBUG) {
			cin = new BufferedReader(new FileReader("d:\\OJ\\uva_in.txt"));
		} else {
			cin = new BufferedReader(new InputStreamReader(System.in));
		}
		tokenizer = new StreamTokenizer(cin);
		
		cout = new PrintWriter(new OutputStreamWriter(System.out));
	}
	
	public int next() throws IOException
	{
		
		tokenizer.nextToken();
		if (tokenizer.ttype == StreamTokenizer.TT_NUMBER) {
			return (int)tokenizer.nval;
		}
		return -1;
	}
	
	private int sum(int x)
	{
		return x * (x + 1) / 2 - 1;
	}
	
	public void solve(int cas, int n)
	{
		int[] num = new int[110];
		
		for (int i = 2; i <= n; i++) {
			if (sum(i + 1) > n) {
				int tmp = sum(i);
				int average = (n - tmp) / (i - 1);
				int remainder = (n - tmp) % (i - 1);
				
				for (int j = 2; j <= i - remainder; j++) num[j] = j + average;
				for (int j = i - remainder + 1; j <= i; j++) num[j] = j + average + 1;
				
				for (int j = 2; j <= i; j++) {
					if (j != 2) cout.print(" ");
					cout.print(num[j]);
				}
				cout.println();
				
				if (cas != 0) cout.println();
				
				cout.flush();
				return;
			}
		}
	}
	
	public static void main(String[] args) throws IOException
	{
		Main solver = new Main();
		solver.init();
		
		int t = solver.next();
		
		while (t-- > 0) {
			int n = solver.next();
			solver.solve(t, n);
		}
		
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值