PAT-甲级-1015

1015. Reversible Primes (20)

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
N
o
【解析】
题目的意思就是叫你判断输入的n和n经过m进制转换后得到的数是不是素数如果都是素数就输出yes否则就是no所以我们就要注意一下进制转换的概念了,排列的话是越先算出
来的越在后面。
#include<cstdio>
#include<iostream>
using namespace std;
int isprime(int n)
{
    int i;
    if(n<2)
        return 0;
    for(i=2;i*i<=n;i++)//判断素数
    {
        if(n%i==0)
            return 0;
    }
    return 1;
}
int change(int n,int d)
{
    int i,j,a[110]={0};
    int cnt=0,sum=0,temp;
    while(n)
    {
        a[cnt++]=n%d;
        n=n/d;
    }
    for(i=cnt-1;i>=0;i--)
    {
        temp=1;
        for(j=0;j<cnt-1-i;j++)//进制转换,数组当中越在前面的d的指数越大
        {
            temp=temp*d;
        }
    sum=sum+a[i]*temp;
    }
    return sum;
}
int main()
{
    int i,j,n,d,m;
    while(scanf("%d",&n))
    {
        if(n<0)
            break;
        scanf("%d",&d);
        m=change(n,d);
        if(isprime(n)==1&&isprime(m)==1)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值