PAT甲级1015

1015. Reversible Primes (20)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.


Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.


Input Specification:


The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.


Output Specification:


For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.


Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes

No

以上是题目,以下是代码

#include<stdio.h>
#include<cmath>
#include<vector>
#include<cstdlib>

using namespace std;

int n,d;
bool prime(int i){
    if(i == 1)
        return false;
    int n = sqrt(i);
    for(int j = 2; j <= n; j++ ){
        if(i%j == 0)
            return false;
    }
    return true;
};
vector<int> tmp;
int re;
int main(){
    while(1){
        scanf("%d",&n);
        re = n;
        if(re < 0)
            break;
        scanf("%d",&d);
        while(re!=0){
            tmp.push_back(re%d);
            re = re/d;
        }
        for(vector<int>::iterator i = tmp.begin(); i!=tmp.end();i++){
            re = re*d + *i;
        }
        tmp.clear();
        if(prime(re)== true && prime(n) == true)
            printf("Yes\n");
        else
            printf("No\n");
    }
    system("pause");
    return 0;
}

 

小结:难度不大,照着题目意思来就可以,唯一需要注意的是1不是素数,分开讨论。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值