ZCMU-1403-Arne Saknussemm

1403: Arne Saknussemm

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 61   Solved: 14
[ Submit][ Status][ Web Board]

Description

Following the account of Jules Verne, a scrambled message written by the middle age alchemist Arne Saknussemm, and deciphered by professor Lidenbrock, started the incredible travel to the center of the Earth. The scrambling procedure used by Arne is alike the procedure given below.

1. Take a non empty message M that contains letters from the English alphabet, digits, commas, dots, quotes (i.e. '), spaces and line breaks, and whose last character is different than space. For example, consider the following message whose translation reads "In Sneffels's crater descend brave traveler, and touch the center of the Earth".

In Sneffels craterem descende audas
viator, et terrestre centrum attinges.

2. Choose an integral number 0<K≤length(M) and add trailing spaces to M such that the length of the resulting message, say M', is the least multiple ofK. For K=19 and the message above, where length(M)=74 (including the 8 spaces and the line break that M contains), two trailing spaces are added yielding the message M' with length(M')=76.

3. Replace all the spaces from M' by the character _ (underscore) ; replace all the line breaks from M' by \ (backslash), and then reverse the message. In our case:

__.segnitta_murtnec_ertserret_te_,rotaiv\sadua_ednecsed_meretarc_sleffenS_nI

4. Write the message that results from step 3 in a table with length(M')/K rows and K columns. The writing is column wise. For the given example, the message is written in a table with 76/19=4 rows and 19 columns as follows:

_

e

t

m

n

e

e

t

_

t

\

u

d

s

m

t

_

f

S

_

g

t

u

e

r

r

_

,

a

s

a

n

e

e

a

s

f

_

.

n

a

r

c

t

r

t

r

i

a

_

e

d

r

r

l

e

n

s

i

_

t

_

s

e

e

o

v

d

e

c

_

e

c

e

n

I

5. The strings of characters that correspond to the rows of the table are the fragments of the scrambled message. The 4 fragments of Arne's message given in step 1 are:

_etmneet_t\udsmt_fS
.narctrtria_edrrlen

_gtuerr_,asaneeasf_
si_t_seeovdec_ecenI

Write a program that deciphers non empty messages scrambled as described. The length of a message, before scrambling, is at most 1000 characters, including spaces and line breaks.

The program input is from a text file where each data set corresponds to a scrambled message. A data set starts with an integer  n, that shows the number of fragments of the scrambled message, and continues with n strings of characters that designate the fragments, in the order they appear in the table from step 4 of the scrambling procedure. Input data are separated by white-spaces and terminate with an end of file.

Output

The deciphered message must be printed on the standard output, from the beginning of a line and must be followed by an empty line as shown in the input/output sample below.

Sample Input

4   _etmneet_t\udsmt_fS
    _gtuerr_,asaneeasf_ 
    .narctrtria_edrrlen 
    si_t_seeovdec_ecenI
11 e n r e V _ s e l u J

Sample Output

In Sneffels craterem descende audas
viator, et terrestre centrum attinges.
Jules Verne

【解析】
这道题的意思就是把文章给倒置,每一列的元素从下到上组成单词,然后就是'_'代表的是空格,而'\'代表的是换行,但是在我们代码判断的时候需要用'\\'这个来判断。需要注意的是行末的空格我们需要把它去掉所以我们就要统计行末空格的数量。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    char a[1001][1001];
    char b[1001];
    int t,i,j,len,count1;
    while(~scanf("%d",&t))
    {
        len=0;
        count1=0;
        for(i=0;i<t;i++)
        {
            cin>>a[i];
        }
        for(j=strlen(a[0])-1;j>=0;j--)
        {
            for(i=t-1;i>=0;i--)
            {
              b[len++]=a[i][j];
            }
        }
        for(j=0;j<strlen(a[0]);j++)
        {
            for(i=0;i<t;i++)
            {
                if(a[i][j]=='_')
                {
                    count1++;
                }
                else if(a[i][j]!='_')
                   {
                       goto out;
                   }
            }
        }
        out:;
        for(i=0;i<len-count1;i++)
        {
            if(b[i]=='_')
                printf(" ");
            else if(b[i]=='\\')
                    printf("\n");
            else
                printf("%c",b[i]);
        }
        printf("\n\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值