Bellman算法PKU 3259

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 31593 Accepted: 11497

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, andW (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
<pre name="code" class="cpp">//John的农地里有N块地,M条路连接两块地。W个虫洞。虫洞是一条单向路,会在你离开之前把你传送到目的地,就是当你过去的时候时间会
//倒退Ts。我们的任务是知道会不会从某块地出发后又回来,看到了离开之前的自己,简化下,就是看图中有没有负权环,有的话就是可以。
//没有的话就是不可以了 。
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <queue>
#include <stack>
#include <deque>
#include <vector>
#include <set>
//#include <map>
using namespace std;

const int VM = 520;
const int EM = 5020;
const int INF = 0x3f3f3f3f;

struct Edge{
    int u,v;
    int w;
}edge[EM<<1];

int N,M,W,cnt,dis[VM];

void addage(int cu,int cv,int cw){
    edge[cnt].u = cu;
    edge[cnt].v = cv;
    edge[cnt].w = cw;
    cnt++;
}

int Bellman(){
    int i,j,flag;
    for(i=0;i<N;i++){
        dis[i] = INF;
    }
    for(i=1;i<N;i++){
        bool flag = false;
        for(j=0;j<cnt;j++){
            if(dis[edge[j].v] > dis[edge[j].u]+edge[j].w){
                dis[edge[j].v] = dis[edge[j].u]+edge[j].w;
                flag = true;
            }
        }
        if(flag==false){
            return false;
        }
    }
    for(i=0;i<cnt;i++){
        if(dis[edge[i].v] > dis[edge[i].u]+edge[i].w){
            return true;
        }
    }

    return false;
}

int main(){
    int t;
    int i;

    while(~scanf("%d",&t)){
        while(t--){
            scanf("%d%d%d",&N,&M,&W);
            cnt = 0;
            int u,v,w;
            for(i=0;i<M;i++){
                scanf("%d%d%d",&u,&v,&w);
                addage(u,v,w);
                addage(v,u,w);
            }
            for(i=0;i<W;i++){
                scanf("%d%d%d",&u,&v,&w);
                addage(u,v,-w);
            }
            if(Bellman()==1){
                printf("YES\n");
            }
            else{
                printf("NO\n");
            }
        }
    }

    return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值