Bellman 算法

博客探讨了使用Bellman算法检测图中是否存在正环的问题,强调在更新路径值时需使其增大,与寻找负环的区别。
摘要由CSDN通过智能技术生成

这道题目其实就是在求有没有正环。与求负环的区别就是要不断的更新值,但是这个值要变大。而不是变小。

Currency Exchange
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 20441 Accepted: 7337

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <queue>
#include <stack>
#include <deque>
#include <vector>
#include <set>
#include <map>
using namespace std;
const int INF = 99999999.9;
const int EM = 5555;
const int VM = 110;
int n,m,s;
double mon;

struct Edge{
    int u,v;
    double com;
    double exg;
}edge[EM<<1];
int cnt;
double dis[VM];
//double mon;

/*void addage(int cu,int vu,double aa,double bb){
    edge[cnt].from = cu;
    edge[cnt].to = vu;
    edge[cnt].com = aa;
    edge[cnt].exg = bb;
    cnt++;
}*/

int Bellman(){
    int i,j,flag;
    for(i=1;i<=n;i++){
        dis[i] = 0.0;
    }
    dis[s] = mon;
    for(i=1;i<n;i++){
        bool flag = false;
        for(j=0;j<cnt;j++){
            int u = edge[j].u;
            int v = edge[j].v;
            double rate = edge[j].exg;
            double cost = edge[j].com;
            if(dis[v]<(dis[u]-cost)*rate)//求最大的路径
            {
                dis[v]=(dis[u]-cost)*rate;
                flag=true;
            }
            //if(dis[edge[j].to] < (dis[edge[j].from]-edge[j].com)*edge[j].exg){
            //    dis[edge[j].to] = (dis[edge[j].from]-edge[j].com)*edge[j].exg;
            //    flag = 1;
            //}
        }
        if(flag==false){
            return false;
        }
    }
    for(j=0; j<cnt; j++)
    {
        if(dis[edge[j].v]<(dis[edge[j].u]-edge[j].com)*edge[j].exg)//与传统的bell不一样,传统的bell是找负环。现在是找正环,正环无限松弛
            return true;
    }
    return false;
}

int main(){
    //int n,m,s;
    //double mon;
    double rab,cab,rba,cba;
    int marka,markb;

    while(~scanf("%d%d%d%lf",&n,&m,&s,&mon)){
        cnt = 0;
        //flag = 1;
        while(m--){
            scanf("%d%d%lf%lf%lf%lf",&marka,&markb,&rab,&cab,&rba,&cba);
            //addage(marka,markb,a2,a1);
            //addage(markb,marka,b2,b1);
            edge[cnt].u=marka,edge[cnt].v=markb,edge[cnt].com=cab,edge[cnt].exg=rab;
            cnt++;
            edge[cnt].u=markb,edge[cnt].v=marka,edge[cnt].com=cba,edge[cnt].exg=rba;
            cnt++;
        }
        if(Bellman()){
            printf("YES\n");
        }
        else{
            printf("NO\n");
        }
    }

    return 0;
}


Bellman算法是用来解决最短路径问题的一种动态规划算法。在C++中,可以使用邻接矩阵或邻接表来表示图,并使用循环来实现Bellman算法。 首先,你需要定义一个图的数据结构,可以使用邻接矩阵或邻接表来表示图的边和权重。然后,你可以使用一个数组来保存每个节点的最短路径值,并初始化它们为无穷大。 接下来,你可以使用循环来迭代计算每个节点的最短路径值。在每次迭代中,遍历图中的所有边,并更新到达每个节点的最短路径值。具体的更新规则是,对于每条边(u, v),如果从起始节点到u的路径加上边(u, v)的权重小于当前已知的从起始节点到v的路径长度,则更新v的最短路径值。 重复上述步骤,直到没有节点的最短路径值发生改变或达到最大迭代次数为止。最后,你可以通过检查最短路径值数组来获得从起始节点到其他节点的最短路径长度。 这是一个简单示例代码,使用邻接矩阵表示图: ```cpp #include <iostream> #include <vector> #include <limits> #define INF std::numeric_limits<int>::max() void bellmanFord(std::vector<std::vector<int>>& graph, int start) { int numNodes = graph.size(); std::vector<int> dist(numNodes, INF); dist[start] = 0; for (int i = 0; i < numNodes - 1; ++i) { for (int u = 0; u < numNodes; ++u) { for (int v = 0; v < numNodes; ++v) { if (graph[u][v] != 0 && dist[u] + graph[u][v] < dist[v]) { dist[v] = dist[u] + graph[u][v]; } } } } // 检查是否存在负权回路 for (int u = 0; u < numNodes; ++u) { for (int v = 0; v < numNodes; ++v) { if (graph[u][v] != 0 && dist[u] + graph[u][v] < dist[v]) { std::cout << "Graph contains negative weight cycle" << std::endl; return; } } } // 输出最短路径值 for (int i = 0; i < numNodes; ++i) { std::cout << "Shortest path from start to node " << i << ": " << dist[i] << std::endl; } } int main() { std::vector<std::vector<int>> graph = { {0, 6, 0, 0, 0}, {0, 0, 5, -4, 0}, {0, -2, 0, 0, 0}, {1, 0, 7, 0, -2}, {2, 0, 0, 8, 0} }; int startNode = 0; bellmanFord(graph, startNode); return 0; } ``` 这个示例代码中的图是一个有向图,使用邻接矩阵表示。你可以根据你的具体需求进行修改和扩展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值