畅通工程 最短路(SPFA)

 

某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。
现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。Input

本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。

Output

对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.

Sample Input

3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2

 

Sample Output

2
-1

 

 

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
#define N 210
#define INF 0x3f3f3f3f
int map[N][N], dis[N];
bool vis[N];
int SPFA(int start,int finish,int n)
{
    memset(vis, 0, sizeof(vis));
    memset(dis, 0x3f, sizeof(dis));
    dis[start] = 0;
    queue<int> q;
    while (!q.empty())
        q.pop();
    q.push(start);
    vis[start] = 1;
    while (!q.empty())
    {
        int u = q.front();
        q.pop();
        vis[u] = 0;
        for (int i = 0; i < n; i++)
            if (map[u][i] < INF && dis[u] + map[u][i] < dis[i])
            {
                dis[i] = dis[u] + map[u][i];
                if (!vis[i])
                    q.push(i), vis[i] = 1;
            }
    }
    return dis[finish];
}
int main()
{
    int n, m, start, finish;
    while (~scanf("%d%d", &n, &m))
    {
        memset(map, 0x3f, sizeof(map));
        for (int i = 1; i <= m; i++)
        {
            int a, b, w;
            scanf("%d%d%d", &a, &b, &w);
            if (w < map[a][b])
                map[a][b] = map[b][a] = w;
        }
        scanf("%d%d", &start, &finish);
        int ans = SPFA(start,finish,n);
        if (ans < INF)
            printf("%d\n", ans);
        else
            printf("-1\n");
    }
    return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值