Catch That Cow(bfs)

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意:给出两个数x,y,第一个代表农场主的位置,第二个代表奶牛的位置,从x到y可以有两种方式,第一种,往左往右走,第二种用传送带可以直接到2*x的位置上,问从x到y至少需要几步。

注意不能越界

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <vector>
#include <map>
#include <string>
#include <deque>
#include <queue>
#include <cstdio>
#include <cstdlib>
#include <set>
#define MAX 0x3f3f3f3f
using namespace std;
typedef long long ll;
const int M=1e5+10;
int aa[M];
priority_queue <int,vector<int>,greater<int> > q;
struct node
{
    int x;
    int time;
} start,now,ff;
int vis[M]={0};
int dir[3]={1,-1,0};
queue <node> dq;
int bfs(int n,int k)
{
    int i;
    memset(vis,0,sizeof(vis));
    vis[n]=1;
    start.x=n;
    start.time=0;
    dq.push(start);
    while(!dq.empty())
    {
        now=dq.front();
        dq.pop();
        if(now.x==k)
            return now.time;
        for(i=0;i<3;i++)
        {
            if(dir[i]!=0)
                start.x=dir[i]+now.x;
            else
                start.x=now.x*2;
            start.time=now.time+1;
            if(start.x>=0&&start.x<=100000)
            {
                if(vis[start.x]==0)
                {dq.push(start);
                vis[start.x]=1;}
            }
        }
    }
    return 0;
}
int main()
{
    int n,k;
    cin>>n>>k;
    int ans=bfs(n,k);
    cout<<ans<<endl;
    return 0;
}

 

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值