HDU 2135 Rolling table

Rolling table

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1219    Accepted Submission(s): 605


Problem Description
After the 32nd ACM/ICPC regional contest, Wiskey is beginning to prepare for CET-6. He has an English words table and read it every morning.
One day, Wiskey's chum wants to play a joke on him. He rolling the table, and tell Wiskey how many time he rotated. Rotate 90 degrees clockwise or count-clockwise each time.
The table has n*n grids. Your task is tell Wiskey the final status of the table.
 

Input
Each line will contain two number.
The first is postive integer n (0 < n <= 10).
The seconed is signed 32-bit integer m.
if m is postive, it represent rotate clockwise m times, else it represent rotate count-clockwise -m times.
Following n lines. Every line contain n characters.
 

Output
Output the n*n grids of the final status.
 

Sample Input
  
  
3 2 123 456 789 3 -1 123 456 789
 

Sample Output
  
  
987 654 321 369 258 147
 

题意:矩阵旋转,顺时针或逆时针,周期是4.

AC代码:

#include<iostream>
using namespace std;
char a[12][12];
int main()
{
	int n,m,i,j,N=0;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		getchar();
		N=m%4;
		for(i=0;i<n;i++)
		{
			for(j=0;j<n;j++)
				scanf("%c",&a[i][j]);
			getchar();
		}
		if(N==0)
		{
			for(i=0;i<n;i++)
			{
				for(j=0;j<n;j++)
					printf("%c",a[i][j]);
				printf("\n");
			}
		}
		else if((N==1)||(N==-3))
		{
			for(i=0;i<n;i++)
			{
				for(j=n-1;j>=0;j--)
					printf("%c",a[j][i]);
				printf("\n");
			}
		}
		else if((N==2)||(N==-2))
		{
			for(i=n-1;i>=0;i--)
			{
				for(j=n-1;j>=0;j--)
					printf("%c",a[i][j]);
				printf("\n");
			}
		}
		else if((N==-1)||(N==3))
		{
			for(i=n-1;i>=0;i--)
			{
				for(j=0;j<n;j++)
					printf("%c",a[j][i]);
				printf("\n");
			}
		}
	}
	return 0;
}


 


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值