SDUT 1028 Catch That Cow (BFS)

题目描述

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

输入

Line 1: Two space-separated integers: N and K

输出

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

示例输入

5 17

示例输出

4


#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>

using namespace std;

struct node
{
	int x, step;
} now,next;

queue <node> q;

int vis[200000];//标记数组,判断这个点是否走过。
int n, m;

int bfs()
{
	while (!q.empty())//每一次都将队列里面的数清空
	{
		q.pop();
	}

	memset(vis, 0, sizeof(vis));
	vis[now.x] = 1;//牧场主开始的位置标记,代表不会走回来
        q.push(now);  //放入队列的末端

	while (!q.empty())//当队列中还有数存在是时候,一直循环
	{

		now = q.front();  //取队列顶端元素,即最初加入的元素

		if(now.x==m)
            return now.step;

		q.pop();

		for (int j = 0; j < 3; j++)//三种情况的循环
		{
            next = now;

			if (j == 0)
			{
				next.x = next.x + 1;
			}
			else if (j == 1)
			{
				next.x = next.x - 1;
			}
			else if (j == 2)
			{
				next.x = next.x * 2;
			}
			next.step++;

			if (next.x == m)
			{
				return next.step;
			}
			if (next.x >= 0 && next.x <= 200000 && !vis[next.x])//判断是否越界
			{
				vis[next.x] = 1;  
				q.push(next);  //每次加入都在队列的末端
			}
		}
	}
return 0;
}

int main()
{
	while (~scanf("%d %d", &n, &m))
	{
		now.x = n;
		now.step=0;
		printf("%d\n", bfs());
	}

	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值