SDUT OJ 1028 Catch That Cow



Catch That Cow

Time Limit: 2000MS Memory limit: 65536K

题目描述

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

输入

Line 1: Two space-separated integers: N and K

输出

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

示例输入

5 17

示例输出

4

提示

这个题的大体意思是 在一个数轴上,人在N位置,牛在K位置,人去找牛,牛不动,人有两种走法,一种是+1或-1,另一种是在x位置,直接跳到2*x位置。
示例是 从5跳到10,再从10到9,从9跳到18,从18到17,走4步,用的步数最少;
#include<bits/stdc++.h>
#define INF 1000000
using namespace std;
int vis[1000100];
int Map[1010];
int n,m;
struct node
{
    int step;
    int data;
}t1,t2;
void BFS()
{
    queue<node>q;
    t1.data=n;
    t1.step=0;
    q.push(t1);
    vis[n]=1;
    while(!q.empty())
    {
        t1=q.front();
        q.pop();
        if(t1.data==m)
        {
            cout<<t1.step<<endl;
            return ;
        }
        int d=t1.data;
        int s=t1.step;
        s++;
        d=t1.data-1;
        if(d>=0&&!vis[d])
        {
            vis[d]=1;
            t2.data=d;
            t2.step=s;
            q.push(t2);
        }
        d=t1.data+1;
        if(d<INF&&!vis[d])
        {
            vis[d]=1;
            t2.data=d;
            t2.step=s;
            q.push(t2);
        }
        d=t1.data*2;
        if(d<INF&&!vis[d])
        {
            vis[d]=1;
            t2.data=d;
            t2.step=s;
            q.push(t2);
        }
    }
}
int main()
{
    while(cin>>n>>m)
    {
        memset(vis,0,sizeof(vis));
        BFS();
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值