PAT (Advanced Level)1099 Build A Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

思路

用一个数组a存树的结构,用一个数组b存树的结点数据。由于是二叉搜索树,中序遍历是从小到大的顺序。所以可以把b数组中的数据从小到大排列,再中序遍历树,把b中的数据送入结点的data里面。最后层序遍历树,把结点的数据输出。

代码 

#include<stdio.h>
#include<algorithm>
using namespace std;
struct node{
	int data,lchild,rchild,index,depth;
}a[110];
int n,b[110],cnt=0;
bool cmp(node a,node b){
	if(a.depth!=b.depth)
		return a.depth<b.depth;
	else
		return a.index<b.index;
}
void dfs(int root,int index,int depth){	//中序遍历 
	if(a[root].lchild==-1&&a[root].rchild==-1){
		a[root]={b[cnt++],-1,-1,index,depth};
	}else{
		if(a[root].lchild!=-1)
			dfs(a[root].lchild,2*index,depth+1);
		a[root]={b[cnt++],a[root].lchild,a[root].rchild,index,depth};
		if(a[root].rchild!=-1)
			dfs(a[root].rchild,2*index+1,depth+1);
	}
}
int main(){
	scanf("%d",&n);
	int t1,t2;
	for(int i=0;i<n;i++){
		scanf("%d%d",&t1,&t2);
		a[i].lchild=t1;
		a[i].rchild=t2;
	}
	for(int i=0;i<n;i++)
		scanf("%d",&b[i]);
	sort(b,b+n);
	dfs(0,0,0); 
	sort(a,a+n,cmp);
	printf("%d",a[0].data);
	for(int i=1;i<n;i++)
		printf(" %d",a[i].data);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值