PAT (Advanced Level)1045 Favorite Color Stripe (30分)

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10​4​​) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

思路

输入先给出喜欢的n个颜色,再给出一个颜色序列,要求在这个颜色序列中找出最长的喜欢的颜色序列(可重复,可不全部出现,但必须按顺序)。这是一个动态规划问题,可以利用最长不下降子序列(LIS)或最长公共子序列(LCS)方法。这道题做法很巧妙,不是直接把输入的数据存下来,而是把输入喜欢的颜色的下标存到数组里(方便利用LIS方法处理)。需要注意的是,存下标要从1开始存,不然在dp遍历的时候无法区分是否是喜欢的颜色。存储颜色序列时,是把其中喜欢的颜色存下来,不喜欢的不处理,而且存的是该颜色的下标,也不是直接存颜色。两种存储都是存下标,题目就转换成了最长不下降子序列问题。

代码 

#include<stdio.h>
#include<algorithm>
using namespace std;
int n,m,ans=-1;
int like[201]={-1},color[10001],dp[10001];
int main(){
	int x,k,cnt=0;
	scanf("%d %d",&n,&m);
	for(int i=1;i<=m;i++){	//注意一定是从1开始 
		scanf("%d",&x);
		like[x]=i;	//喜欢的颜色x下标为i 
	}
	scanf("%d",&k);
	for(int i=0;i<k;i++){
		scanf("%d",&x);
		if(like[x]>=1)	//输入的颜色中有喜欢的才存起来,否则不处理 
			color[cnt++]=like[x];	//存入数组的是喜欢颜色的下标 
	} 
	//状态转移方程 
	for(int i=0;i<cnt;i++){
		dp[i]=1;
		for(int j=0;j<i;j++){
			if(color[j]<=color[i])
				dp[i]=max(dp[i],dp[j]+1);
		}
		ans=max(ans,dp[i]);
	}
	printf("%d",ans);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值