A - Marjar Cola

Marjar Cola is on sale now! In order to attract more customers, Edward, the boss of Marjar Company, decides to launch a promotion: If a customer returns x empty cola bottles or y cola bottle caps to the company, he can get a full bottle of Marjar Cola for free!

Now, Alice has a empty cola bottles and b cola bottle caps, and she wants to drink as many bottles of cola as possible. Do you know how many full bottles of Marjar Cola she can drink?

Note that a bottle of cola consists of one cola bottle and one bottle cap.

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤T ≤ 100), indicating the number of test cases. For each test case:

The first and only line contains four integers xyab (1 ≤ xyab ≤ 100). Their meanings are described above.

Output

For each test case, print one line containing one integer, indicating the number of bottles of cola Alice can drink. If Alice can drink an infinite number of bottles of cola, print "INF" (without the quotes) instead.

Sample Input
2
1 3 1 1
4 3 6 4
Sample Output
INF
4
Hint

For the second test case, Alice has 6 empty bottles and 4 bottle caps in hand. She can return 4 bottles and 3 caps to the company to get 2 full bottles of cola. Then she will have 4 empty bottles and 3 caps in hand. She can return them to the company again and get another 2 full bottles of cola. This time she has 2 bottles and 2 caps in hand, but they are not enough to make the exchange. So the answer is 4.



判断他是不是重复,就可以解决INF,判断可不可以兑换,就可以输出答案。

代码如下:
  

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

int f[1005][1005];
int x,y,z,t;

int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0; i<n; i++)
    {

        scanf("%d%d%d%d",&x,&y,&z,&t);
        memset(f,0,sizeof(f));
        int ans =0;
        while(true)
        {
            f[z][t] = 1;
            if(z>=x)
            {
                int o = z/x;
                z-=x*o;
                z+=o;
                t+=o;
                ans+=o;
                // cout<<t<<z<<endl;
            }
            if(t>=y)
            {
                int o = t/y;
                t-=o*y;
                z+=o;
                t+=o;
                ans+=o;
                // cout<<t<<z<<endl;
            }

            if(z<x && t<y)
            {
                printf("%d\n",ans);
                break;
            }

            if(f[z][t] || x==1 || y==1)
            {
                printf("INF\n");
                break;
            }


        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值