Agri-Net Prim(Kruskal)的应用

描述

 

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.

Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.

Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.

The distance between any two farms will not exceed 100,000.

 

输入

 

INPUT FORMAT For Each Test Data

Line 1:The number of farms, N (3 <= N <= 100).
Line 2...N+1:The subsequent lines contain the N x N connectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

 

输出

 

OUTPUT FORMAT For Each Test Data

The single output contains the integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

 

样例输入

 

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

 

样例输出

 

28

 

代码如下:

import java.util.Scanner;
import java.util.ArrayList;
import java.util.Collections;
import java.util.List;

class map implements Comparable {
	int length;
	int x;
	int y;
	public int compareTo(Object o) {
		map s = (map) o;
		return length - s.length;
	}
}

public class Main {
    ///一个标记的数组
	private static int flag[];
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int nodenumber = sc.nextInt();
		List<map> list = new ArrayList<map>();
		for (int i = 0; i < nodenumber; i++) {
			for (int j = 0; j < nodenumber; j++) {
				map data = new map();
				data.length = sc.nextInt();
				data.x = i;
				data.y = j;
				list.add(data);
			}
		}
		/// 开始每一个节点的父节点,初始化为自己。
		flag = new int[nodenumber];
		for (int i = 0; i < nodenumber; i++)
			flag[i] = i;
		/// 开始选择,节点,建造路径。
         Collections.sort(list);
         ///初始化一些值
         int sum =0 ,edge = 0;
         for(int i=0;i<list.size();i++)
         {
        	 if(!union(list.get(i).x,list.get(i).y))
        		 continue;
        	 edge++;
        	 sum+= list.get(i).length;
        	 if(edge==nodenumber-1)
        		 break;
         }
         System.out.println(sum);
	}
	
	private static int find(int p)  
	{   
	    while (p != flag[p]) 
	    	p = flag[p]; 
	    return p;  
	}  
	public static boolean union(int p, int q)  
	{   
	    int pRoot = find(p);  
	    int qRoot = find(q);  
	    ///一个村子里面的,就不需要搬
	    if (pRoot == qRoot)   
	        return  false;  
	    ///个人喜好问题,是搬到哪边村子,同名
	    flag[pRoot] = qRoot; 
	   return true;
	}  
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值