02-线性结构3 Reversing Linked List (25 分)

线性结构3 Reversing Linked List (25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​ ) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

//本题要用数组模拟内存,用序号代表地址
#include<stdio.h>
#include<stdlib.h>
#pragma warning(disable:4996);//防止VS调试报错
typedef struct LinkedListNode* LinkedList;
const int MAXSIZE=100002;//数组(即“内存”)大小,[100001]位置用来表示临时头结点
struct LinkedListNode{
    int x;//节点存储的
    int next;//下一个节点的“地址”
};

LinkedList read(int num){
    LinkedList list=(LinkedList)malloc(MAXSIZE*sizeof(struct LinkedListNode));
    int addr,next,x;
    while(num--){
        scanf("%d %d %d",&addr,&x,&next);
        list[addr].x=x;
        list[addr].next=next;
    }
    return list;
}

int count(LinkedList list,int first){
    int num=1;
    for(int here=first;(list+here)->next!=-1;num++)
        here=(list+here)->next;
    return num;
}

void print_list(const LinkedList list,int first){
    int serialNum=first;//offset,即节点所在位置
    while(list[serialNum].next!=-1){
        //printf("%[flags] [width] [.precision] [{h | l | I64 | L}]type")
        //其中flags是指正负号和前导0或空格
        printf("%05d %d %05d\n",serialNum,list[serialNum].x,list[serialNum].next);
        serialNum=list[serialNum].next;//"指针"指向下一个节点        
    }
    printf("%05d %d %d\n",serialNum,list[serialNum].x,list[serialNum].next);//输出最后一个结点
}

//返回
int reverse(LinkedList list,int head,int length,int k){
    int segments=length/k;
    int preTail=MAXSIZE-1;//用来表示上一段链表逆序后的尾结点
	list[preTail].next = head;//初始化空头结点链接至待逆序链表
    int thisHead=head;//本段当前头结点,亦即重拍后链表段的尾结点
    while(segments--){
        //头插法逆序链表
        for(int i=0;i<k-1;i++){
            int target=list[thisHead].next;//待插入节点在已逆序链表段尾的下一个
            list[thisHead].next=list[target].next;//已逆序链表段尾链接到未排序段头
            list[target].next=list[preTail].next;//待插入节点指向已逆序链表段头
            list[preTail].next=target;//上段尾结点指向本段新头结点,即target
        }
        preTail=thisHead;//本段的新尾结点诞生
        thisHead=(list+thisHead)->next;//thisHead指向下一段的开头
    }
    return list[MAXSIZE-1].next;
}

int main(){
    int head,num,k;//链表头“地址”,输入节点数,逆序长度
    scanf("%d %d %d",&head,&num,&k);
    LinkedList list=read(num);//读取输入,创建链表
    int length=count(list,head);//获得链表实际长度
    //print_list(list,head);
    int newHead=reverse(list,head,length,k);//逆转链表并获得新头结点
    print_list(list,newHead);
    return 0;
}

题目描述 给定一个常数 $K$ 以及一个单链表 $L$,请编写程序将 $L$ 中每 $K$ 个结点反转。例如:给定 $L$ 为 1→2→3→4→5→6,$K$ 为 3,则输出应该为 3→2→1→6→5→4;如果 $K$ 为 4,则输出应该为 4→3→2→1→5→6,即最后不到 $K$ 个元素不反转。 输入格式 每个输入包含一个测试用例。每个测试用例第 1 行给出第 1 个结点的地址、结点总个数正整数 $N (\le 10^5)$、以及正整数 $K (\le N)$,即要求反转的子链结点的个数。结点的地址是 5 位非负整数,NULL 地址用 −1 表示。 接下来有 $N$ 行,每行格式为: Address Data Next 其中 Address 是结点地址;Data 是该结点保存的整数数据;Next 是下一结点的地址。题目保证给出的链表不为空。 输出格式 对每个测试用例,顺序输出反转后的链表,其上每个结点占一行,格式与输入相同。 输入样例 00100 6 4 00000 4 99999 00100 1 12309 68237 6 -1 33218 3 00000 99999 5 68237 23333 2 33218 输出样例 00000 4 33218 33218 3 12309 12309 1 99999 99999 5 68237 68237 6 23333 23333 2 -1 题目析 本题需要将链表中每 $K$ 个结点反转,可以采用迭代的方法,每次找到 $K$ 个结点,将这 $K$ 个结点反转,然后将这 $K$ 个结点的前驱结点指向反转后的第一个结点,将反转后的 $K$ 个结点的最后一个结点指向下一个要反转的结点,然后继续进行下一轮反转。 需要注意的是,如果链表长度不足 $K$,则不进行反转。 代码实现
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值