Rational Arithmetic(模拟分数的加减乘除

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:
Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:
For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:
2/3 -4/2
Sample Output 1:
2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)
Sample Input 2:
5/3 0/6
Sample Output 2:
1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

#include<bits/stdc++.h>
#include <iostream>
#include <map>
#include <string>
#include<vector>
#include<stack>
using namespace std;
long long gcd(long long a,long long b) {
	long long c;
	while(b) {
		c=a%b;
		a=b;
		b=c;
	}
	return a;
}
void print(long long fenzi,long long fenmu) {
	long long g=gcd(fenzi,fenmu);
	fenzi/=g;
	fenmu/=g;

	long long p=fenzi*fenmu;
	fenzi=abs(fenzi);
	fenmu=abs(fenmu);
	if(p<0) {
		cout<<"(-";
	}
	if(fenzi==0) {
		cout<<"0";
	} else if(fenmu==0) {
		cout<<"Inf";
	} else {
		long long dai=fenzi/fenmu;
		if(dai) {
			cout<<dai;
		}
		long long zhenfenzi=fenzi%fenmu;
		if(zhenfenzi) {
			if(dai)cout<<" ";
			cout<<zhenfenzi<<"/"<<fenmu;
		}
	}
	if(p<0) {
		cout<<")";
	}

}
int main() {
	long long a,b,c,d;
	scanf("%lld/%lld %lld/%lld",&a,&b,&c,&d);
	long long fenzi,fenmu;
	
	fenzi=a*d+b*c;
	fenmu=b*d;
	
	print(a,b);
	cout<<" + ";
	print(c,d);
	cout<<" = ";
	print(fenzi,fenmu);
	cout<<endl;
	
	fenzi=a*d-b*c;
	print(a,b);
	cout<<" - ";
	print(c,d);
	cout<<" = ";
	print(fenzi,fenmu);
	cout<<endl;
	
	fenzi=a*c;
	print(a,b);
	cout<<" * ";
	print(c,d);
	cout<<" = ";
	print(fenzi,fenmu);
	cout<<endl;
	
	fenzi=a*d;
	fenmu=b*c;
	print(a,b);
	cout<<" / ";
	print(c,d);
	cout<<" = ";
	print(fenzi,fenmu);
	cout<<endl;
	
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值