An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.
Now given a sequence of insertions, you are supposed to output the level-order traversal sequence of the resulting AVL tree, and to tell if it is a complete binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 20). Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, insert the keys one by one into an initially empty AVL tree. Then first print in a line the level-order traversal sequence of the resulting AVL tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line. Then in the next line, print YES
if the tree is complete, or NO
if not.
Sample Input 1:
5
88 70 61 63 65
Sample Output 1:
70 63 88 61 65
YES
Sample Input 2:
8
88 70 61 96 120 90 65 68
Sample Output 2:
88 65 96 61 70 90 120 68
NO
#include<bits/stdc++.h>
#include<set>
#include<vector>
#include<map>
#include<queue>
int n;
using namespace std;
struct node{
int data;
int high;
struct node *lc,*rc;
};
int judge=1,cnt=0;
void levelout(struct node root)
{
queue<struct node>q;
q.push(root);
while(q.size())
{
if(q.front().lc) q.push( *q.front().lc );
if(q.front().rc) q.push( *q.front().rc );
if(q.front().lc)
{
if((cnt+1)*2>n)judge=0;
}
if(q.front().rc)
{
if((cnt+1)*2+1>n)judge=0;
}
cnt == 0 ? cout << q.front().data : cout << " " << q.front().data;
q.pop();
cnt++;
}
cout<<endl;
judge == 1 ? cout << "YES" : cout << "NO";
}
int gethigh(struct node *root)
{
if(root)return max(gethigh(root->lc),gethigh(root->rc))+1;
else return 0;
}
struct node *ll(struct node *root)
{
struct node *p=root->lc;
root->lc=p->rc;
p->rc=root;
root->high=max(gethigh(root->lc),gethigh(root->rc))+1;
p->high=max(gethigh(root->lc),root->high)+1;
return p;
}
struct node *rr(struct node *root)
{
struct node *p=root->rc;
root->rc=p->lc;
p->lc=root;
root->high=max(gethigh(root->lc),gethigh(root->rc))+1;
p->high=max(gethigh(root->rc),root->high)+1;
return p;
}
struct node *rl(struct node *root)
{
root->rc=ll(root->rc);
return rr(root);
}
struct node *lr(struct node *root)
{
root->lc=rr(root->lc);
return ll(root);
}
struct node *insert(struct node *root,int data)
{
if(!root)
{
root=new struct node();
root->data=data;
}
else if(data<root->data)
{
root->lc=insert(root->lc,data);
if(gethigh(root->lc)-gethigh(root->rc)==2)
if(data<root->lc->data)root=ll(root);
else root=lr(root);
}
else if(data> root->data)
{
root->rc=insert(root->rc,data);
if(gethigh(root->rc)-gethigh(root->lc)==2)
if(data>root->rc->data)root=rr(root);
else root=rl(root);
}
root->high=max(gethigh(root->lc),gethigh(root->rc))+1;
return root;
}
int main() {
int tmp;
cin>>n;
struct node *root=NULL;
for(int i=0;i<n;i++)
{
cin>>tmp;
root=insert(root,tmp);
}
levelout(*root);
return 0;
}