The Balance(母函数)

The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5655    Accepted Submission(s): 2285


Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 

Sample Input
  
  
3 1 2 4 3 9 2 1
 

Sample Output
  
  
0 2 4 5
 

Source
HDU 2007-Spring Programming Contest

模板题:

AC代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>

using namespace std;
const int M = 10005;

int a[110],b[M],c[M];

int main()
{
    int n,sum,ans,res,to;
    while(~scanf("%d",&n))
    {
        sum = 0;
        for(int i = 0; i < n; i++)
        {
            scanf("%d",a + i);
            sum += a[i];
        }
        memset(b,0,(sum + 1) * sizeof(int));
        memset(c,0,(sum + 1) * sizeof(int));
        b[0] = b[a[0]] = 1;
        ans = a[0];
        res = to = 0;
        for(int i = 1; i < n; i++)
        {
            for(int j = 0; j <= ans; j++)
            {
                for(int k = 0; k + j <= sum && k <= a[i]; k += a[i])
                {
                    int t = abs(j - k);
                    c[j + k] += b[j];
                    c[t] += b[j];
                }
            }
            ans += a[i];
            for(int j = 0; j <= ans; j++)
            {
                b[j] = c[j];
                c[j] = 0;
            }
        }
        for(int i = 1; i <= sum; i++)
        {
            if(b[i] == 0)
            {
                a[to++] = i;
                res++;
            }
        }
        printf("%d\n",res);
        for(int i = 0; i < to; i++)
            printf(i == to - 1 ? "%d\n" : "%d ",a[i]);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值