The Balance(母函数变形)

The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8706    Accepted Submission(s): 3649


Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 

Sample Input
 
 
3 1 2 4 3 9 2 1
 

Sample Output
 
 
0 2 4 5
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2152  1708  2082  1721  1701 

题意:给你n个数,在这些数字的和之下,无法通过任意两个数加或减得到的数字有哪些。

不同于以往的母函数的地方是这道题里面还可以将两个数相减,处理方式则可以当后面那个多项式的指数是负数将两个指数相减同时取绝对值即可,同时因为一开始的超时,优化了一下我的母函数模板。

#include<stdio.h>
#include <algorithm>
#include<iostream>
#include<string.h>
#include<vector>
#include<stdlib.h>
#include<math.h>
#include<queue>
#include<deque>
#include<ctype.h>
#include<map>
#include<set>
#include<stack>
#include<string>
#include<algorithm>
#define ll long long
#define INF 0x3f3f3f3f
#define FAST_IO ios::sync_with_stdio(false)
const double PI = acos(-1.0);
const double eps = 1e-6;
using namespace std;

int c1[250000],c2[250000],v[250000];
int main()
{
    int n;
    while(cin>>n && n>0)
    {
        int sum=0;
        memset(c1,0,sizeof(c1));
        memset(c2,0,sizeof(c2));
        memset(v,0,sizeof(v));

        for(int i=1;i<=n;i++)
        {
            cin>>v[i];
            sum+=v[i];
        }

        c1[0]=1;
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<=sum;j++)
                for(int k=0;k+j<=sum && k<=v[i];k+=v[i])
                {
                    c2[k+j]+=c1[j];
                    c2[abs(k-j)]+=c1[j];
                }
            for(int j=0;j<=sum;j++)
			{
				c1[j]=c2[j];
				c2[j]=0;
			}
        }
        int flag=0,ans=0;

        for(int i=1;i<=sum;i++)
            if(!c1[i])
                ans++;

        cout<<ans<<endl;
        for(int i=1;i<=sum;i++)
            if(!c1[i])
            {
                if(!flag)
                {
                    cout<<i;
                    flag=1;
                }
                else
                    cout<<" "<<i;
            }

        if(flag)
        cout<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值