B - Prime Path(BFS)

B - Prime Path

Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

意解:题目给出两个素数n,m,问是否可以从n变为m; 直接对每一个位BFS;

AC代码:
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
using namespace std;
typedef long long ll;
const int M = 10000;
int check[M],prime[M],tot,ny,Min;
bool vis;
bool map[10000];//标记已经BFS过的;
int n,m,T;
/**********/

struct Node //存储每个数和到达该数的时间
{
    int x,t;
};

void make_prime() //把四位数的素数存储进prime数组
{
    tot = 0;
    for(int i = 2; i < M; i++)
    {
        if(!check[i])
        {
            if(i > 1000) prime[tot++] = i;
            for(int j = i + i; j < M; j += i)
                check[j] = 1;
        }
    }
}

void bfs()
{
    Node tp;
    tp.x = n;
    tp.t = 0;
    map[n] = true;
    queue<Node>ms;
    ms.push(tp);
    while(!ms.empty())
    {
        tp = ms.front();
        ms.pop();
        int d[4],i = 0,t = tp.x;
        while(t)
        {
            d[i++] = t % 10;
            t /= 10;
        }
        for(i = 0; i < 4; i++)
        {
            for(int j = 0; j <= 9; j++)
            {
                if(j == d[i]) continue;
                if(i == 0 && (j % 2 == 0 || j == 5)) continue; //本身不是素数的,直接退出
                if(i == 3 && j == 0) continue;//首位不能为0
                int u = 3,sum = 0;
                while(u != -1)
                {
                    if(u == i)
                    {
                        sum = sum * 10 + j;
                    }
                    else sum = sum * 10 + d[u];
                    u--;
                }
                if(check[sum] || map[sum]) continue;//合数或者已被标记过的,直接退出
                Node c;
                map[sum] = true;
                c.x = sum;
                c.t = tp.t + 1;
                if(sum == m)
                {
                    vis = 1;
                    printf("%d\n",c.t);
                    return;
                }
                ms.push(c);
            }
        }
    }
}


int main()
{
    make_prime();
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d",&n,&m);
        memset(map,false,sizeof(map));
        if(n == m) puts("0");
        else
        {
            vis = 0;
            bfs();
            if(!vis) puts("Impossible");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值