Number Theory(数论-对数)

    X - Number Theory

Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Factorial of an integer is defined by the following function

f(0) = 1

f(n) = f(n - 1) * n, if(n > 0)

So, factorial of 5 is 120. But in different bases, the factorial may be different. For example, factorial of 5 in base 8 is 170.

In this problem, you have to find the number of digit(s) of the factorial of an integer in a certain base.

Input

Input starts with an integer T (≤ 50000), denoting the number of test cases.

Each case begins with two integers n (0 ≤ n ≤ 106) and base (2 ≤ base ≤ 1000). Both of these integers will be given in decimal.

Output

For each case of input you have to print the case number and the digit(s) of factorial n in the given base.

Sample Input

5

5 10

8 10

22 3

1000000 2

0 100

Sample Output

Case 1: 3

Case 2: 5

Case 3: 45

Case 4: 18488885

Case 5: 1


意解: 题意给出n和k,叫你求出n的阶乘的k进制数有多少位; 此处用到了对数的知识.

         先说下对数的换底公式, 有loga ^ b = logc ^ b / log c ^ a; 容易证明这是正确的,高中的知识....

         之后对于求一个数x的位数,我们先从10进制数说起,假设求100000的位数,我们知道其有6为数,

        可以把其化为10^5,而易知log10(10^ 5) = 5,即其位数为log10(x) + 1;类比其他进制数就很自然了;

AC代码:

         

#include <iostream>
#include <cstdio>
#include <cmath>

using namespace std;
typedef long long ll;
const int M = 1e6 + 100;
double lo[M];

void unit()
{
    for(int i = 1; i < M; i++)
        lo[i] = lo[i - 1] + log10(i);
}
int main()
{
   int T,n,k,cnt = 0;
   scanf("%d",&T);
   unit();
   while(T--)
   {
       scanf("%d %d",&n,&k);
       printf("Case %d: %d\n",++cnt,(int)(lo[n] / log10(k)) + 1);
   }
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值