Little Zu Chongzhi's Triangles(计算几何加贪心)

Little Zu Chongzhi's Triangles

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 75    Accepted Submission(s): 39


Problem Description
Zu Chongzhi (429–500) was a prominent Chinese mathematician and astronomer during the Liu Song and Southern Qi Dynasties. Zu calculated the value ofπ to the precision of six decimal places and for a thousand years thereafter no subsequent mathematician computed a value this precise. Zu calculated one year as 365.24281481 days, which is very close to 365.24219878 days as we know today. He also worked on deducing the formula for the volume of a sphere.

It is said in some legend story books that when Zu was a little boy, he liked mathematical games. One day, his father gave him some wood sticks as toys. Zu Chongzhi found a interesting problem using them. He wanted to make some triangles by those sticks, and he wanted the total area of all triangles he made to be as large as possible. The rules were :

1) A triangle could only consist of 3 sticks.
2) A triangle's vertexes must be end points of sticks. A triangle's vertex couldn't be in the middle of a stick.
3) Zu didn't have to use all sticks.

Unfortunately, Zu didn't solve that problem because it was an algorithm problem rather than a mathematical problem. You can't solve that problem without a computer if there are too many sticks. So please bring your computer and go back to Zu's time to help him so that maybe you can change the history.
 

Input
There are no more than 10 test cases. For each case:

The first line is an integer N(3 <= N<= 12), indicating the number of sticks Zu Chongzhi had got. The second line contains N integers, meaning the length of N sticks. The length of a stick is no more than 100. The input ends with N = 0.
 

Output
For each test case, output the maximum total area of triangles Zu could make. Round the result to 2 digits after decimal point. If Zu couldn't make any triangle, print 0.00 .
 

Sample Input
  
  
3 1 1 20 7 3 4 5 3 4 5 90 0
 

Sample Output
  
  
0.00 13.64
 

Source
2014ACM/ICPC亚洲区广州站-重现赛(感谢华工和北大)

意解: 对海伦公式进行化简,最后可以得出三角形的三条边越大,其面积则越大,则可以先对输入的数从大到小排序,然后顺序枚举三角形的三条边,符合条件的则算出其

面积,继续枚举下去.

AC代码:

/**三角形面积S之海伦公式
 * 已知三角形三条边长度a,b,c
 * 设p = (a + b + c) >> 1;
 * 则S = sqrt(p * (p - a) * (p - b) * (p - c));
 */
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
const int M = 20;
double dp[M];

bool cmp(double a,double b)
{
    return a > b;
}

double area(double a,double b,double c)
{
    double p = (a + b + c) / 2;
    double S = sqrt(p * (p - a) * (p - b) * (p - c));
    return S;
}

int main()
{
    int n;
    while(cin>>n && n)
    {
        double res = 0.00;
        for(int i = 0; i < n; i++)
            scanf("%lf",dp + i);
        sort(dp,dp + n,cmp);
        for(int i = 0; i + 2 < n; i++)
        {
            if(dp[i] < dp[i + 1] + dp[i + 2])
            {
                res += area(dp[i],dp[i + 1],dp[i + 2]);
                i += 2;
            }
        }
        printf("%.2f\n",res);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值