Largest Rectangle in a Histogram(POJ-2559)

Largest Rectangle in a Histogram
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22186 Accepted: 7178

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer  n, denoting the number of rectangles it is composed of. You may assume that  1<=n<=100000. Then follow  n integers  h1,...,hn, where  0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is  1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

Hint

Huge input, scanf is recommended.

Source


题意理解:找出这里面面积最大的矩形。

解题思路:这就是一道单调栈的题,找出每个端点能到达的左右边界。就可以了。

首先确定左边界 若栈为空,则压入东西,若不是,则比较栈顶元素的值和要压入的值得大小关系,比栈顶大,压入,比栈顶小,把栈顶元素弹出,并更新要压入元素左边界,直到遇到比要压入元素小的值,或者栈为空时,压入该元素。

#include<stdio.h>
#include<stack>
using namespace std;
struct s{
   long long  x;
   long long l;
   long long  r;
}a[100010];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            return 0;
        for(int i=0;i<n;i++)
        {
            scanf("%lld",&a[i].x);
            a[i].l=i;
            a[i].r=i;
        }
        stack<s>q;
        for(int i=0;i<n;i++)   //确定左端点
        {
            if(q.empty())
            {
                q.push(a[i]);
            }
            else
            {
                if(q.top().x<a[i].x)
                {
                    q.push(a[i]);
                }
                else
                {
                    while(q.top().x>=a[i].x)
                    {
                        a[i].l=q.top().l;
                        q.pop();
                        if(q.empty())
                        {
                            break;
                        }
                    }
                   q.push(a[i]);
                }
            }
        }
        while(!q.empty())
        {
            q.pop();
        }
        for(int i=n-1;i>=0;i--)    //确定右端点
        {
            if(q.empty())
            {
                q.push(a[i]);
            }
            else
            {
                if(q.top().x<a[i].x)
                {
                    q.push(a[i]);
                }
                else
                {
                    while(q.top().x>=a[i].x)
                    {
                        a[i].r=q.top().r;
                        q.pop();
                        if(q.empty())
                        {
                            break;
                        }
                    }
                    q.push(a[i]);
                }
            }
        }
        long long ans;
        long long max_=0;
        for(int i=0;i<n;i++)
        {
            ans=(long long)((a[i].r-a[i].l+1)*a[i].x);
            if(max_<ans)
            {
                max_=ans;
            }
        }
        printf("%lld\n",max_);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值