1115. Counting Nodes in a BST (30)

题目:

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
The right subtree of a node contains only nodes with keys greater than the node’s key.
Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000) which is the size of the input sequence. Then given in the next line are the N integers in [-1000 1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:
9
25 30 42 16 20 20 35 -5 28
Sample Output:
2 + 4 = 6

解答:

#include<cstdio>
#include<vector>
using namespace std;
struct node{
    int data;
    node* left,*right;
};
node* insert(node* &root,int data){
    if(root==NULL){
        root=new node;
        root->data=data;
        root->left=root->right=NULL;
    } else if(data<=root->data) root->left=insert(root->left,data);
    else root->right=insert(root->right,data);
    return root;
}
int d[1010],maxDepth=0;
void DFS(node* root ,int depth){
    if(root==NULL){
        maxDepth=max(maxDepth,depth);
        return;
    }
    d[depth]++;
    DFS(root->left,depth+1);
    DFS(root->right,depth+1);
}
int main(){
    int n,temp;
    node* root=NULL;///
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",&temp);
        root=insert(root,temp);
    }
    DFS(root,0);
    printf("%d + %d = %d\n",d[maxDepth-1],d[maxDepth-2],d[maxDepth-1]+d[maxDepth-2]);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值