【找规律】hdu6267 Master of Random

Master of Random

题目描述

Hakase provides Nano with a problem. There is a rooted tree with values on nodes. For each query,you are asked to calculate the sum of the values in the subtree. However, Nano is a rookie so she decides to guess the answer. She has known how the data generator works: it identifi es the nodes with labels from 0 to n-1 and then visits them one by one. For each i (1≤i≤n), the generator selects a node whose label is smaller than i to be its father. The pseudocode is like this:
          for i = 1 to n - 1:
             father[i] = random(0, i - 1);
where random(a, b) randomly generates a uniformly distributed random integer in range [a, b].
Knowing n and the value of the i-th node ai , Nano decides to randomly choose a subtree and sum up all of the values in the subtree as the answer. Now Hakase wants to know what the expectation of the answer is. Can you help her?

 

输入

The first line contains an integer T (1≤T≤10) representing the number of test cases.
For each test case, the fi rst line contains an integer n (1≤n≤100000), the number of the nodes in the rooted tree.
The second line contains n integers a0,a1,...,an-1 (1≤ai≤100000) represent the values of nodes.

 

输出

It can be proven that the answer equals to an irreducible fraction p/q. For each test case, print p*q-1 mod 998244353 in one line. q-1 is the inverse of q under module number 998244353.

 

样例输入

 

2
2
1 1
3
1 2 3

样例输出

499122178
166374063

提示

The shape of the tree in the fi rst test case is unique. The father of node 1 is 0. It is possible to choose node 0 or 1 with equal possibility. The sum of the subtree with 0 as the root is 2 while the sum of the subtree with 1 as the root is 1. So the expectation is (2 + 1)/2 = 3/2. The output is 3*2-1 mod 998244353 = 400122178.
There are two possible shapes in the second test case, node 1’s father destines to be 0, but node 2’s father might be node 0 or node 1. Both conditions are equally possible.
If node 2’s father is node 0, we randomly choose a node. The sum of the subtree with node 0 as the root is 6. The sum of the subtree with node 1 as the root is 2. The sum of the subtree with node 2 as the root is 3.
If node 2’s father is node 1, we randomly choose a node. The sum of the subtree with node 0 as the root is 6. The sum of the subtree with node 1 as the root is 5. The sum of the subtree with node 2 as the root is 3.
So the expectation is (6 + 2 + 3 + 6 + 5 + 3)/6 = 25/6. The output is 25*6-1 mod 998244353 = 166374063.


参考博客:【找规律】hdu6267 CCPC杭州17 D - Master of Random

【题意】:

只能比自己小的节点作为自己的父节点,请问每个节点出现的次数

一个树,0号节点是它的根,1到n-1号节点依次,等概率地认已经确定地节点为爸爸。比如k就等概率地认0-k-1中的一个为爸爸。每个点都有一个权值,随机选一个点,求它子树大小,对所有的树,所有的点,求期望。

0号节点频率为(n-1)!/n! 
1号:(n-1)!+(n-1)!/1/n 
2号:(n-1)!+(n-1)!/1+(n-1)!/2/n! 


#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N = 1e5+100;
const ll mod=998244353;
ll qpow(ll a,ll b){
    ll ans = 1 ;
    while(b){
        if(b&1){
            ans = ans *a%mod;
        }
        a=a*a%mod;
        b>>=1;
    }
    return ans;
}
ll a[N];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%lld",&a[i]);
        //reverse(a+1,a+1+n);
        ll tmp = 1,t=0;
        for(ll i=1;i<n;i++)
            tmp = tmp*i%mod;
        t = tmp;
        ll ans = tmp*a[1];
        for(ll i=1;i<n;i++){
            t = (t + tmp*qpow(i,mod-2)%mod)%mod;
            ans = (ans + t*a[i+1])%mod;
        }
        tmp = (tmp*n)%mod;
        ans = ans * qpow(tmp,mod-2)%mod;
        printf("%lld\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值