HDU5569(dp)

matrix

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 598    Accepted Submission(s): 345


Problem Description
Given a matrix with  n  rows and  m  columns (  n+m  is an odd number ), at first , you begin with the number at top-left corner (1,1) and you want to go to the number at bottom-right corner (n,m). And you must go right or go down every steps. Let the numbers you go through become an array  a1,a2,...,a2k . The cost is  a1a2+a3a4+...+a2k1a2k . What is the minimum of the cost?
 

Input
Several test cases(about  5 )

For each cases, first come 2 integers,  n,m(1n1000,1m1000)

N+m is an odd number.

Then follows  n  lines with  m  numbers  ai,j(1ai100)
 

Output
For each cases, please output an integer in a line as the answer.
 

Sample Input
  
  
2 3 1 2 3 2 2 1 2 3 2 2 1 1 2 4
 

Sample Output
  
  
4 8
 

Source
 

Recommend
hujie
 

分析:和hihocoder第五周的的题类似,不过这个多了2种情况,对边界特判即可。dp[i][j]表示到达这一点的最小值,并且i+j必须是奇数。

 代码:

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
long long dp[1005][1005];
int a[1005][1005];
int n,m;
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                scanf("%d",&a[i][j]);
            }
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                if((i+j)%2==0) continue;
                if(i==1)
                {
                    dp[i][j]=dp[1][j-2]+a[1][j-1]*a[1][j];
                    continue;
                }
                if(j==1)
                {
                    dp[i][j]=a[i-1][1]*a[i][1]+dp[i-2][1];
                    continue;
                }
                if(j!=1&&i!=1)
                {
                   dp[i][j]=min((long long)dp[i-1][j-1]+a[i-1][j]*a[i][j],(long long)dp[i-1][j-1]+a[i][j-1]*a[i][j]);
                   if(i-2>=1)
                   {
                      dp[i][j]=min(dp[i][j],dp[i-2][j]+(long long)a[i-1][j]*a[i][j]);
                   }
                   if(j-2>=1)
                   {
                       dp[i][j]=min(dp[i][j],dp[i][j-2]+(long long)a[i][j-1]*a[i][j]);
                   }
                }
            }
        }
        printf("%I64d\n",dp[n][m]);
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值