Poj-2236 Wireless Network


题目直通车 POJ-2236

知识要点:并查集

Wireless Network
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 22625 Accepted: 9491

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

   
   
4 1
0 1
0 3
0 2
0 4
O 4
O 1 O 2
S 1 4
S 1 4
O 3

Sample Output

   
   
FAIL
SUCCESS

题目意思:

大致上就是地震之后有N 台电脑损坏,现在想要创建无线网络,无线网络能够通讯的长度为d.当输入为 O p 时,修理电脑p;当输入为 S p q 时候,询问p,q能否联通。

样例分析:

4 台电脑,无线通讯距离为1,  四台电脑坐标分别为 (0,1)  (0,2)  (0,3) (0,4) . 然后修理电脑 1,2,4 (那么此时1,2能够互相通讯,4 独立)  当修理电脑3时,(1,2,3,4)都能相互通讯。

代码:

#include <stdio.h>
#include <math.h>
int pre[3000];
int find (int x)
{
	int r = x;
	while (pre[r]!=r)
	{
		r = pre[r];                 // 找到 x 的最上级
	}
	int i = x,j;
	while (pre[i]!=r)                   // 压缩路径, 将并查集压缩为只有两级的树(根节点,叶节点)
	{
		j = pre[i];
		pre[i] = r;
		i = j;	
	}
	return r;
}
void mix(int x,int y)                       // 将 x,y接通,成为一个集合
{
	int fx = find(x),fy = find(y);
	if(fx!=fy)
	{
		pre[fy]=fx;
	}
}
struct computer
{
	int x;
	int y;
}com[3000];
int main()
{
	int N,a,i,x,y;
	char c;
	int rep[3000];
	int repcont=1;
	scanf("%d%d",&N,&a);
	for(i=1;i<=N;i++)
	{
		scanf("%d%d",&com[i].x,&com[i].y);
	}
	for(i=0;i<=N;i++)
	{
		pre[i]=i;                      // 初始化前驱数组
	}
	while (scanf("%c",&c)!=EOF)
	{
		if(c=='O')
		{
			scanf("%d",&x);
			rep[repcont++]=x;       // 将修好的电脑存入数组
			for(i=1;i<repcont;i++)  // 遍历已修好的电脑
			{
				if((sqrt(pow((com[rep[i]].x-com[x].x),2)+pow((com[rep[i]].y-com[x].y),2)))<=a)
				mix(rep[i],x);                                //如果当前电脑和已修好的电脑能够互通,那么混合
			}
	
		}
		else if(c=='S') 
		{
			scanf("%d%d",&x,&y);
			if(find(x)==find(y))                                 
			{
				printf("SUCCESS\n");
			}
			else 
			printf("FAIL\n");
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值