[POJ 2240]Arbitrage[spfa]

Arbitrage

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24332 Accepted: 10299

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

Source

Ulm Local 1996

题意

给定n种货币, m种兑换关系, 问是否可以通过兑换来赚钱。
【poj 1860】昨天刚写一份题解,类似于这道题,似乎这道题更简单一些。

题解

正权回路判断。
需要注意的是输入的处理,以及建图。
spfa需要修改的就是dis初值赋为0,起点dis赋为1,更新条件改为dis[v] < dis[x] * cost即可。
参见【POJ 1860 题解】

#include <cstdio>
#include <iostream>
#include <queue>
#include <map>
#include <cmath>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
const int MAX_V = 110;
struct edge{
  int to;
  double cost;
  edge(int _to, double _cost): to(_to), cost(_cost){}
};
int N;
map<string, int> mmp;
vector<edge> G[MAX_V];
double dis[MAX_V];
int cnt[MAX_V];
bool vis[MAX_V];
void init()
{
  for(int i = 0; i <MAX_V; i++)
    G[i].clear();
}
void addedge(int u, int v, double w)
{
  G[u].push_back(edge(v, w));
}
bool spfa_bfs(int s)
{
  memset(dis, 0, sizeof dis);
  memset(vis, 0, sizeof vis);
  memset(cnt, 0, sizeof cnt);
  queue<int> q;
  dis[s] = 1, vis[s] = 1, cnt[s] = 1;
  q.push(s);
  while(!q.empty())
  {
    int x = q.front(); q.pop();
    vis[x] = 0;
    for(int i = 0; i < G[x].size(); i++)
    {
      int v = G[x][i].to;
      double cost = G[x][i].cost;
      if(dis[v] < dis[x] * cost)
      {
        dis[v] = dis[x] * cost;
        if(!vis[v])
        {
          vis[v] = 1;
          cnt[v]++;
          q.push(v);
          if(cnt[v] > N) return 0;
        }
      }
    }
  }
  return 1;
}
int main()
{
  int cas = 1;
  while(cin >> N)
  {
    if(N == 0)  break;
    mmp.clear();
    init();
    for(int i = 1; i <= N; i++)
    {
      string a;
      cin >> a;
      mmp[a] = i;
    }
    int M;
    cin >> M;
    for(int i = 1; i <= M; i++)
    {
      string a, b;
      int u, v;
      double rate;
      cin >> a >> rate >> b;
      u = mmp[a], v =mmp[b];
      addedge(u, v, rate);
    }
    cout << "Case " << cas ++ << ": ";
    if(!spfa_bfs(1))  cout << "Yes" << endl;
    else  cout << "No" << endl;

  }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值